summaryrefslogtreecommitdiff
path: root/app-arch/lziprecover
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lziprecover')
-rw-r--r--app-arch/lziprecover/Manifest5
-rw-r--r--app-arch/lziprecover/lziprecover-1.17.ebuild26
-rw-r--r--app-arch/lziprecover/lziprecover-1.20.ebuild27
-rw-r--r--app-arch/lziprecover/metadata.xml51
4 files changed, 109 insertions, 0 deletions
diff --git a/app-arch/lziprecover/Manifest b/app-arch/lziprecover/Manifest
new file mode 100644
index 000000000000..8850ce30990a
--- /dev/null
+++ b/app-arch/lziprecover/Manifest
@@ -0,0 +1,5 @@
+DIST lziprecover-1.17.tar.gz 75941 BLAKE2B 7b9e464ceac83571516a879a4809029219e05de43268d6febc0d1a9f5e86c869489dde2af87992d1d7d1bb8755f68f0f9d001f0cdd8971679acf54bea1568f52 SHA512 409a3634ef15238f8c87e6e69ecf0cf83c48274cff6c54a901a4f80bdc3d475b6bf03215cfee762ac64ca41b3e8a805ab620ceaaa1bec7fc22ffafad049b5f0f
+DIST lziprecover-1.20.tar.gz 102574 BLAKE2B 2b8a1d30d9094655d14978d935755083e4ce1168565745cd412cc56d110261a34afc335882e0e74edc7c87843f24698f6834395056381dbb170b229b68be4da8 SHA512 cb036869bc2bccd6ee56793ced03a4ce8556e6da1e2840934f12f2b9e1d9a9362c66c40483c061e7c3f817e739e4ed6488bd964b03c031b7c26cc99c2ee24867
+EBUILD lziprecover-1.17.ebuild 655 BLAKE2B cf7c042eeb532d477b001826e82979c4e9c8c9a0b1e5db50f5b6064fe0697ba8bbce7226ddacbf7797478771668a8ebf7acafa66def5a1db7af22036da2defa0 SHA512 0bdfe46c55ad1416c454091b228b39130e7cedb624a3d08eb6a05309f219304874628fd6874464a8832dcda7fc7c607c98374ba7700eaa7d15a543e4d60a504e
+EBUILD lziprecover-1.20.ebuild 725 BLAKE2B 4f1906842981415232cda50f7976a21b40846c8a35434b41275623ed8efdc14af5563370af5c217a92ada4729a81af4bd1313de9767dc8d6c9782b7e72ecc6a8 SHA512 f6823acd1549f0b7b31160d7eac788b68f9e6a769904f7039e7b0769a2733547956b1ff1b9c2a63aec23fed17ab7e1838b94d9cea913529b6f55566e9cbd8f9d
+MISC metadata.xml 2674 BLAKE2B 470d5c221311328b1620bc51fb5ccb6393f04e9a1d0367fcef04579061b9d88ac5bb131e050eb2cd3e2a8608db58586cf49bef3e58ca320d93398aba7579799b SHA512 c39f9d4478cdc3e5865567f5e6560e4fa34f014aa6538ca47a1dddf51f1d5549f8edcee34dda36e691bd28b734a8df4c04ff0a94d68c16caccc22e57c35a7823
diff --git a/app-arch/lziprecover/lziprecover-1.17.ebuild b/app-arch/lziprecover/lziprecover-1.17.ebuild
new file mode 100644
index 000000000000..5e7b8947ad16
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for lzip compressed files"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/lziprecover-1.20.ebuild b/app-arch/lziprecover/lziprecover-1.20.ebuild
new file mode 100644
index 000000000000..bd72f2a3510b
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for lzip compressed files"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz
+ http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/metadata.xml b/app-arch/lziprecover/metadata.xml
new file mode 100644
index 000000000000..5e2c4af9ecad
--- /dev/null
+++ b/app-arch/lziprecover/metadata.xml
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <longdescription lang="en">
+ Lziprecover is a data recovery tool and decompressor for files in the lzip
+ compressed data format (.lz), able to repair slightly damaged files,
+ recover badly damaged files from two or more copies, extract data from
+ damaged files, decompress files and test integrity of files.
+ The lzip file format is designed for long-term data archiving. It is clean,
+ provides very safe 4 factor integrity checking, and is backed by the
+ recovery capabilities of lziprecover.
+ Lziprecover is able to recover or decompress files produced by any of the
+ compressors in the lzip family; lzip, plzip, minilzip/lzlib, clzip and
+ pdlzip.
+ Lziprecover makes lzip files resistant to bit-flip (one of the most common
+ forms of data corruption), and can safely merge multiple damaged backup
+ copies.
+ If the cause of file corruption is damaged media, the combination GNU
+ ddrescue + lziprecover is the best option for recovering data from multiple
+ damaged copies.
+ If a file is too damaged for lziprecover to repair it, all the recoverable
+ data in all members of the file can be extracted with the '-D' option.
+ Lziprecover is able to efficiently extract a range of bytes from a
+ multi-member file, because it only decompresses the members containing the
+ desired data.
+ Lziprecover can print correct total file sizes and ratios even for
+ multi-member files.
+ When recovering data, lziprecover takes as arguments the names of the
+ damaged files and writes zero or more recovered files depending on the
+ operation selected and whether the recovery succeeded or not. The damaged
+ files themselves are never modified.
+ When decompressing or testing file integrity, lziprecover behaves like lzip
+ or lunzip.
+ To give you an idea of its possibilities, when merging two copies, each of
+ them with one damaged area affecting 1 percent of the copy, the probability
+ of obtaining a correct file is about 98 percent. With three such copies the
+ probability rises to 99.97 percent. For large files (a few MB) with small
+ errors (one sector damaged per copy), the probability approaches 100 percent
+ even with only two copies.
+ Lziprecover is not a replacement for regular backups, but a last line of
+ defense for the case where the backups are also damaged.
+ </longdescription>
+</pkgmetadata>