summaryrefslogtreecommitdiff
path: root/app-arch/xar/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/xar/files')
-rw-r--r--app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch46
-rw-r--r--app-arch/xar/files/xar-1.5.2-respect_ldflags.patch21
-rw-r--r--app-arch/xar/files/xar-1.6.1-ext2.patch24
3 files changed, 91 insertions, 0 deletions
diff --git a/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch b/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch
new file mode 100644
index 000000000000..54ad8f725314
--- /dev/null
+++ b/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch
@@ -0,0 +1,46 @@
+diff -ur xar-1.5.2.orig/configure.ac xar-1.5.2/configure.ac
+--- xar-1.5.2.orig/configure.ac 2007-12-29 20:49:57.000000000 +0200
++++ xar-1.5.2/configure.ac 2008-05-19 17:07:23.000000000 +0300
+@@ -181,8 +181,13 @@
+ )
+ AC_SUBST([enable_autogen])
+
++AC_ARG_ENABLE(acl, AC_HELP_STRING([--disable-acl], [disable support for libacl (default=autodetect)]), [ enable_acl=$enableval ], [ enable_acl=yes ])
++
++if test "x$enable_acl" = "xyes"; then
+ AC_TRY_COMPILE([#include <sys/types.h>
+ #include <sys/acl.h>], [acl_t a], [AC_DEFINE([HAVE_SYS_ACL_H],[1], [define if you have sys/acl.h and it has a working acl_t type])])
++fi
++
+ AC_CHECK_HEADERS(ext2fs/ext2_fs.h sys/statfs.h sys/xattr.h sys/param.h sys/extattr.h libutil.h)
+ AC_CHECK_FUNCS(lgetxattr)
+ AC_CHECK_FUNCS(lsetxattr)
+@@ -251,7 +256,9 @@
+ AC_ERROR(can not detect the size of your system's dev_t type)
+ fi
+
+-AC_CHECK_LIB(acl, acl_get_file)
++if test "x$enable_acl" = "xyes"; then
++ AC_CHECK_LIB(acl, acl_get_file)
++fi
+
+ dnl Check for paths
+ AC_PREFIX_DEFAULT(/usr/local)
+@@ -342,9 +349,14 @@
+ dnl
+ dnl Configure libbz2.
+ dnl
+-have_libbz2="1"
+-AC_CHECK_HEADERS([bzlib.h], , [have_libbz2="0"])
+-AC_CHECK_LIB([bz2], [BZ2_bzCompress], , [have_libbz2="0"])
++AC_ARG_ENABLE(bzip2, AC_HELP_STRING([--disable-bzip2], [disable support for libbz2 (default=autodetect)]), [ enable_bzip2=$enableval ], [ enable_bzip2=yes ])
++
++if test "x$enable_bzip2" = "xyes"; then
++ have_libbz2="1"
++ AC_CHECK_HEADERS([bzlib.h], , [have_libbz2="0"])
++ AC_CHECK_LIB([bz2], [BZ2_bzCompress], , [have_libbz2="0"])
++fi
++
+ if test "x${have_libbz2}" = "x1" ; then
+ AC_DEFINE([HAVE_LIBBZ2])
+ fi
diff --git a/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch b/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch
new file mode 100644
index 000000000000..1ac090d94863
--- /dev/null
+++ b/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch
@@ -0,0 +1,21 @@
+diff -ur xar-1.5.2.orig/lib/Makefile.inc.in xar-1.5.2/lib/Makefile.inc.in
+--- xar-1.5.2.orig/lib/Makefile.inc.in 2007-12-29 20:49:57.000000000 +0200
++++ xar-1.5.2/lib/Makefile.inc.in 2010-04-07 01:18:59.027890429 +0300
+@@ -134,7 +134,7 @@
+ $(LIBRXAR_S) : $(LIBXAR_SRCS:@srcroot@%.c=@objroot@%.o)
+ @mkdir -p $(@D)
+ ifeq (elf, @abi@)
+- $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ @LIBS@
++ $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@
+ endif
+ ifeq (macho, @abi@)
+ $(CC) -dynamiclib -compatibility_version @LIB_REV@ -current_version @LIB_REV@ -install_name @abs_objroot@$(LIBRXAR_S) -o $@ $+ $(LDFLAGS) @LIBS@
+@@ -150,7 +150,7 @@
+ $(LIBXAR_S) : $(LIBXAR_SRCS:@srcroot@%.c=@objroot@%.o)
+ @mkdir -p $(@D)
+ ifeq (elf, @abi@)
+- $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ @LIBS@
++ $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@
+ endif
+ ifeq (macho, @abi@)
+ $(CC) -dynamiclib -compatibility_version @LIB_REV@ -current_version @LIB_REV@ -install_name $(LIBDIR)/$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@
diff --git a/app-arch/xar/files/xar-1.6.1-ext2.patch b/app-arch/xar/files/xar-1.6.1-ext2.patch
new file mode 100644
index 000000000000..da413b03e522
--- /dev/null
+++ b/app-arch/xar/files/xar-1.6.1-ext2.patch
@@ -0,0 +1,24 @@
+--- a/lib/ext2.c.orig
++++ b/lib/ext2.c
+@@ -139,8 +139,10 @@
+ if(! (flags & ~EXT2_NOCOMPR_FL) )
+ x_addprop(f, "NoCompBlock");
+ #endif
++#ifdef EXT2_ECOMPR_FL
+ if(! (flags & ~EXT2_ECOMPR_FL) )
+ x_addprop(f, "CompError");
++#endif
+ if(! (flags & ~EXT2_BTREE_FL) )
+ x_addprop(f, "BTree");
+ if(! (flags & ~EXT2_INDEX_FL) )
+@@ -225,8 +227,10 @@
+ if( e2prop_get(f, "NoCompBlock", (char **)&tmp) == 0 )
+ flags |= EXT2_NOCOMPR_FL ;
+ #endif
++#ifdef EXT2_ECOMPR_FL
+ if( e2prop_get(f, "CompError", (char **)&tmp) == 0 )
+ flags |= EXT2_ECOMPR_FL ;
++#endif
+ if( e2prop_get(f, "BTree", (char **)&tmp) == 0 )
+ flags |= EXT2_BTREE_FL ;
+ if( e2prop_get(f, "HashIndexed", (char **)&tmp) == 0 )