summaryrefslogtreecommitdiff
path: root/app-arch/xar/xar-1.5.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/xar/xar-1.5.2-r1.ebuild')
-rw-r--r--app-arch/xar/xar-1.5.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/xar/xar-1.5.2-r1.ebuild b/app-arch/xar/xar-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..4f493f664b6a
--- /dev/null
+++ b/app-arch/xar/xar-1.5.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools base eutils
+
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://github.com/mackyle/xar"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="acl +bzip2"
+
+DEPEND="dev-libs/openssl
+ dev-libs/libxml2
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ bzip2? ( app-arch/bzip2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( TODO )
+PATCHES=( "${FILESDIR}/${P}-automagic_acl_and_bzip2.patch"
+ "${FILESDIR}/${P}-respect_ldflags.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoconf
+}
+
+src_configure() {
+ econf $(use_enable acl) $(use_enable bzip2)
+}