summaryrefslogtreecommitdiff
path: root/app-arch/xz-utils
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/xz-utils')
-rw-r--r--app-arch/xz-utils/Manifest6
-rw-r--r--app-arch/xz-utils/metadata.xml13
-rw-r--r--app-arch/xz-utils/xz-utils-5.2.3.ebuild91
-rw-r--r--app-arch/xz-utils/xz-utils-5.2.4-r2.ebuild95
-rw-r--r--app-arch/xz-utils/xz-utils-9999.ebuild92
5 files changed, 297 insertions, 0 deletions
diff --git a/app-arch/xz-utils/Manifest b/app-arch/xz-utils/Manifest
new file mode 100644
index 000000000000..14d9626b57da
--- /dev/null
+++ b/app-arch/xz-utils/Manifest
@@ -0,0 +1,6 @@
+DIST xz-5.2.3.tar.gz 1490665 BLAKE2B 470791a67fe635165559b0364c9c0e968f3fc32ba7af53d0173d620ca65c68428e0d4d18ada341a063ea3eabb1b51a71cf873218ca0622fd41e01c20a6f04078 SHA512 a5eb4f707cf31579d166a6f95dbac45cf7ea181036d1632b4f123a4072f502f8d57cd6e7d0588f0bf831a07b8fc4065d26589a25c399b95ddcf5f73435163da6
+DIST xz-5.2.4.tar.gz 1572354 BLAKE2B 877242324afd3c7eb21d3a9414c53843f4d1bb089206e8e545e280b32ff5372f7fb4a1b0c27cb6fdf0d0a27a668e9772ecc3fffc181df95d081ca9c2e987b83b SHA512 e5bf6eb88365d2dbdc774db49261fb9fae0544ed297891fc20f1ed223f4072cb0357cbd98146ac35b6d29410a12b6739bbd111cd57d4a225bef255ed46988578
+EBUILD xz-utils-5.2.3.ebuild 2600 BLAKE2B 3543e5f2c3021c9243b4484359fefd4705d6f7cef894ea14aa54190ff07f7b75e63996efcbd7c809b3125084c572b0141902bda3afce0bffd004ca43912818f8 SHA512 1e60ce955c6b67554ba5e59d1d7eb7d4ed37b830c4ea2d039732232057039a6b4a5b626bc333f93fa61e63c967ba3a33514427466e7ecdbb7db8e12f289950f4
+EBUILD xz-utils-5.2.4-r2.ebuild 2723 BLAKE2B 6e7f66aafe7a6422a1652f824b23b279861d660a468eefa9fdbbd99c24802b0a7ebe8cad19f938d521b9f85ecb0ad256b9e91e45220849a096cee173c8d94eee SHA512 a8b47c2cb48f427561dc278280c569bb62b09c1f52102d55e4fe12c534a571b5901be1d899d6be93d1fe65a3d81a38b42a540caf873d4084ba6b4cf4b590e290
+EBUILD xz-utils-9999.ebuild 2669 BLAKE2B 78a6e7face7f1eb0eaaca0fcf483e92c8304571a082f14e9eb8b3593822bf0684a687949f10e63e88406e723d6d99ff7207a13a8b66a71c75c96a83adb56bfe5 SHA512 614cd4bc390b0f12c0859f1f60f008528a32ec02b15e95b3cffed30c921dacc937f3bc8536bd39ed0c2f43c1e3cfaba894fd325588f4ab7ef6ce5fa319511c3d
+MISC metadata.xml 462 BLAKE2B 66d5625b239d042389ce8fef820efdc3ce3b5cbf21f6d0aedc4874d450ea1897dc8438575f3efc5a491ea857a8b990e6a51b16d0ff0b4982b41307bb52535cf1 SHA512 8f4ca7b987587a240f932ff1719f096de148db6e11c4e0af5f2f55552cab5d0af1256be337dbe8493b584d2c25a70a308dc28b90712078fb58f40cae37cfe5b1
diff --git a/app-arch/xz-utils/metadata.xml b/app-arch/xz-utils/metadata.xml
new file mode 100644
index 000000000000..fac09b73379a
--- /dev/null
+++ b/app-arch/xz-utils/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<use>
+ <flag name='extra-filters'>Build additional filters that are not
+ used in any of the default xz presets. This includes delta
+ and BCJ coders, additional match finders and SHA256 checks.</flag>
+</use>
+</pkgmetadata>
diff --git a/app-arch/xz-utils/xz-utils-5.2.3.ebuild b/app-arch/xz-utils/xz-utils-5.2.3.ebuild
new file mode 100644
index 000000000000..337c639f0bf5
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.2.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI=5
+
+inherit multilib toolchain-funcs libtool multilib-minimal preserve-libs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.tukaani.org/xz.git"
+ inherit git-r3 autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="https://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="https://tukaani.org/xz/"
+
+# See top-level COPYING file as it outlines the various pieces and their licenses.
+LICENSE="public-domain LGPL-2.1+ GPL-2+"
+SLOT="0"
+IUSE="elibc_FreeBSD +extra-filters nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+# Tests currently do not account for smaller feature set
+RESTRICT="!extra-filters? ( test )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautopoint
+ eautoreconf
+ else
+ elibtoolize # to allow building shared libs on Solaris/x64
+ fi
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable nls)
+ $(use_enable threads)
+ $(use_enable static-libs static)
+ )
+ multilib_is_native_abi ||
+ myconf+=( --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts} )
+ if ! use extra-filters; then
+ myconf+=(
+ # LZMA1 + LZMA2 for standard .lzma & .xz files
+ --enable-encoders=lzma1,lzma2
+ --enable-decoders=lzma1,lzma2
+ # those are used by default, depending on preset
+ --enable-match-finders=hc3,hc4,bt4
+ # CRC64 is used by default, though some (old?) files use CRC32
+ --enable-checks=crc32,crc64
+ )
+ fi
+
+ use elibc_FreeBSD && export ac_cv_header_sha256_h=no #545714
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ gen_usr_ldscript -a lzma
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ rm "${ED}"/usr/share/doc/xz/COPYING* || die
+ mv "${ED}"/usr/share/doc/{xz,${PF}} || die
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
diff --git a/app-arch/xz-utils/xz-utils-5.2.4-r2.ebuild b/app-arch/xz-utils/xz-utils-5.2.4-r2.ebuild
new file mode 100644
index 000000000000..dd59406bd52a
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.2.4-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI=6
+
+inherit multilib toolchain-funcs libtool multilib-minimal preserve-libs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.tukaani.org/xz.git"
+ inherit git-r3 autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="https://tukaani.org/xz/${MY_P}.tar.gz"
+ [[ "${PV}" == *_alpha* ]] || [[ "${PV}" == *_beta* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${MY_P}"
+ EXTRA_DEPEND=
+fi
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="https://tukaani.org/xz/"
+
+# See top-level COPYING file as it outlines the various pieces and their licenses.
+LICENSE="public-domain LGPL-2.1+ GPL-2+"
+SLOT="0"
+IUSE="elibc_FreeBSD +extra-filters nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+# Tests currently do not account for smaller feature set
+RESTRICT="!extra-filters? ( test )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautopoint
+ eautoreconf
+ else
+ elibtoolize # to allow building shared libs on Solaris/x64
+ fi
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable nls)
+ $(use_enable threads)
+ $(use_enable static-libs static)
+ )
+ multilib_is_native_abi ||
+ myconf+=( --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts} )
+ if ! use extra-filters; then
+ myconf+=(
+ # LZMA1 + LZMA2 for standard .lzma & .xz files
+ --enable-encoders=lzma1,lzma2
+ --enable-decoders=lzma1,lzma2
+ # those are used by default, depending on preset
+ --enable-match-finders=hc3,hc4,bt4
+ # CRC64 is used by default, though some (old?) files use CRC32
+ --enable-checks=crc32,crc64
+ )
+ fi
+
+ use elibc_FreeBSD && export ac_cv_header_sha256_h=no #545714
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ gen_usr_ldscript -a lzma
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+ rm "${ED%/}"/usr/share/doc/${PF}/COPYING* || die
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
diff --git a/app-arch/xz-utils/xz-utils-9999.ebuild b/app-arch/xz-utils/xz-utils-9999.ebuild
new file mode 100644
index 000000000000..6916173e206e
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI=6
+
+inherit multilib toolchain-funcs libtool multilib-minimal preserve-libs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.tukaani.org/xz.git"
+ inherit git-r3 autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="https://tukaani.org/xz/${MY_P}.tar.gz"
+ [[ "${PV}" == *_alpha* ]] || [[ "${PV}" == *_beta* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${MY_P}"
+ EXTRA_DEPEND=
+fi
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="https://tukaani.org/xz/"
+
+# See top-level COPYING file as it outlines the various pieces and their licenses.
+LICENSE="public-domain LGPL-2.1+ GPL-2+"
+SLOT="0"
+IUSE="elibc_FreeBSD +extra-filters nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+# Tests currently do not account for smaller feature set
+RESTRICT="!extra-filters? ( test )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautopoint
+ eautoreconf
+ else
+ elibtoolize # to allow building shared libs on Solaris/x64
+ fi
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable nls)
+ $(use_enable threads)
+ $(use_enable static-libs static)
+ )
+ multilib_is_native_abi ||
+ myconf+=( --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts} )
+ if ! use extra-filters; then
+ myconf+=(
+ # LZMA1 + LZMA2 for standard .lzma & .xz files
+ --enable-encoders=lzma1,lzma2
+ --enable-decoders=lzma1,lzma2
+ # those are used by default, depending on preset
+ --enable-match-finders=hc3,hc4,bt4
+ # CRC64 is used by default, though some (old?) files use CRC32
+ --enable-checks=crc32,crc64
+ )
+ fi
+
+ use elibc_FreeBSD && export ac_cv_header_sha256_h=no #545714
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ gen_usr_ldscript -a lzma
+}
+
+multilib_src_install_all() {
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+ rm "${ED%/}"/usr/share/doc/${PF}/COPYING* || die
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
+}