summaryrefslogtreecommitdiff
path: root/app-benchmarks/filebench
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/filebench')
-rw-r--r--app-benchmarks/filebench/Manifest4
-rw-r--r--app-benchmarks/filebench/filebench-1.4.9.1-r1.ebuild34
-rw-r--r--app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch22
-rw-r--r--app-benchmarks/filebench/metadata.xml18
4 files changed, 78 insertions, 0 deletions
diff --git a/app-benchmarks/filebench/Manifest b/app-benchmarks/filebench/Manifest
new file mode 100644
index 000000000000..2de70ffd47d3
--- /dev/null
+++ b/app-benchmarks/filebench/Manifest
@@ -0,0 +1,4 @@
+AUX filebench-fix-automagic-libtecla-dependency.patch 1088 BLAKE2B b2acdc8e02b7bececb6680c0a7131443bf2ddf56ce24105713d23f005109651049ffc7e7859c8762402d50b85ca44e1a04351ce65884c835a22d77d72e31c655 SHA512 8c04b18d77749757bb98718ddc086637c9f541c48a2651e28b0d48586d4794feaa86eff1dafbe0c2c93bfe7ac2d090ab8fb38216f5999152309118ff3247b35d
+DIST filebench-1.4.9.1.tar.gz 349535 BLAKE2B 774eab935fba422064c9c6a5c233b99545b639b4319cb9658b6555d087f1af0f59c29de57a5fef94c2256199f1c328d2309641785d8573832629fb4a28b2e716 SHA512 a6400aba4266fcf98e46c4824796a594adc5d5e7f9605f6e1ab01973ce448e27948991e453b186947a8d89f8603a69a3ba955edf2a1abccd2935196af7b6f0d1
+EBUILD filebench-1.4.9.1-r1.ebuild 667 BLAKE2B 1c54c571520c9b20b9e53b3486bac3443c4a2a91fb7cb3a1788bcd90c46aa1a4a3b458cd1241c1138b7bef74de8dc86d335e4fb85d7267876d5b2db05dd6cedf SHA512 228a7297e0018c5616d34da4cf8151ca475e0b74f9ac3eecf2747687483cc6137899e77f4c5d4de8f16bde5f8f01eb802856ba97685ff654c35659da3526178b
+MISC metadata.xml 564 BLAKE2B f5ce812261f5426873a7b34b02e805a77f2e3a8fb5114a47007fa38064c88233c0f9c752d89d6da5386c92ab4115852571027ec0d4a1f0e0f98d3a7ec92e1d2a SHA512 3e0c33f3b4430560ad83c2391814d563e9a10df1521fa606c6517da33bdd256ecd0c6303e7f06e2b7695347aaa838dd70cc02329ae1dd17e08b1144cc5ea5c79
diff --git a/app-benchmarks/filebench/filebench-1.4.9.1-r1.ebuild b/app-benchmarks/filebench/filebench-1.4.9.1-r1.ebuild
new file mode 100644
index 000000000000..44380cce37a5
--- /dev/null
+++ b/app-benchmarks/filebench/filebench-1.4.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Filebench - A Model Based File System Workload Generator"
+HOMEPAGE="https://sourceforge.net/projects/filebench/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="auto-completion"
+
+RDEPEND="
+ auto-completion? ( dev-libs/libtecla )
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-fix-automagic-libtecla-dependency.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with auto-completion libtecla)
+}
diff --git a/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch b/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch
new file mode 100644
index 000000000000..8d24a62a89d6
--- /dev/null
+++ b/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch
@@ -0,0 +1,22 @@
+From: Göktürk Yüksek <gokturk@binghamton.edu>
+Subject: [PATCH] Fix automagic dependency on libtecla
+
+Replace the unconditional AC_CHECK_LIB logic with AC_ARG_WITH to
+eliminate the automagic dependency on libtecla.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -164,8 +164,11 @@
+ AC_CHECK_LIB([kstat], [kstat_open])
+ # Use libtecla for autocompletion if it is available. If it
+ # is, then conditionally compile auto_comp.c (see Makefile.am)
+-AC_CHECK_LIB([tecla], [cpl_add_completion])
+-AM_CONDITIONAL(AUTOCOMP_LIBTECLA, test "$ac_cv_lib_tecla_cpl_add_completion" = yes)
++AC_ARG_WITH([libtecla], AS_HELP_STRING([--with-libtecla], [Build with libtecla for autocompletion support (default: test)]))
++AS_IF([test "x$with_libtecla" != "xno"], [
++ AC_CHECK_LIB([tecla], [cpl_add_completion])
++])
++AM_CONDITIONAL([AUTOCOMP_LIBTECLA], [test "x$ac_cv_lib_tecla_cpl_add_completion" = "xyes"])
+ # Check that librt is installed and supports async IO. First line
+ # allows to add librt to the linkers path, second one checks
+ # if aio_wait() is in it, third one checks if aio_waitn() is there (usually
diff --git a/app-benchmarks/filebench/metadata.xml b/app-benchmarks/filebench/metadata.xml
new file mode 100644
index 000000000000..27ee8b7ca8d0
--- /dev/null
+++ b/app-benchmarks/filebench/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <use>
+ <flag name="auto-completion">Enable command-line autocompletion using <pkg>dev-libs/libtecla</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">filebench</remote-id>
+ </upstream>
+</pkgmetadata>