summaryrefslogtreecommitdiff
path: root/app-cdr/cddetect
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cddetect')
-rw-r--r--app-cdr/cddetect/Manifest3
-rw-r--r--app-cdr/cddetect/cddetect-2.1.ebuild28
-rw-r--r--app-cdr/cddetect/metadata.xml5
3 files changed, 36 insertions, 0 deletions
diff --git a/app-cdr/cddetect/Manifest b/app-cdr/cddetect/Manifest
new file mode 100644
index 000000000000..14ea25c51f68
--- /dev/null
+++ b/app-cdr/cddetect/Manifest
@@ -0,0 +1,3 @@
+DIST cddetect-2.1.tar.gz 11779 BLAKE2B 2e71d923a37d8c1248e4fd0f33349bbec767ef39c31153de3615a5b19f071812e1064b49df5de8d380d2ef7d63adc3dc059bbf37bc9caa3421f70e42fee7f40b SHA512 1a67a17f1d26db8361fd72201afa108571fe8639d34e0bea6fd47a26ea6dfa9ff535c56fd14739d9ee551efdcf74c261e6e4b208e769d066926ee96c400ed54c
+EBUILD cddetect-2.1.ebuild 561 BLAKE2B 9b464650ef4edf613180d807647e340980178d6b1015ad9db40d58a38ced3983c14270ae7041d48cf2db45aa0655657fc0e523d1c1c8f6955d098e1e877e3305 SHA512 98d96929cbf4397d7ed61213feea1cf0e5cdfbcddb51c108879dd588daae48a5a453d9d66fb005dcb3548bde68554297fa37b3b89bd89c9bce52ac34323ceb1d
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-cdr/cddetect/cddetect-2.1.ebuild b/app-cdr/cddetect/cddetect-2.1.ebuild
new file mode 100644
index 000000000000..5de6bf19692a
--- /dev/null
+++ b/app-cdr/cddetect/cddetect-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for detecting the type of a CD/DVD without mounting it"
+HOMEPAGE="http://www.bellut.net/projects.html"
+SRC_URI="http://www.bellut.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed -i -e '1i#include <limits.h>' ${PN}.c || die #337628
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-Wall ${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-cdr/cddetect/metadata.xml b/app-cdr/cddetect/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-cdr/cddetect/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>