summaryrefslogtreecommitdiff
path: root/app-containers/amazon-ecr-credential-helper
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/amazon-ecr-credential-helper')
-rw-r--r--app-containers/amazon-ecr-credential-helper/Manifest4
-rw-r--r--app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.9.0.ebuild30
-rw-r--r--app-containers/amazon-ecr-credential-helper/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/app-containers/amazon-ecr-credential-helper/Manifest b/app-containers/amazon-ecr-credential-helper/Manifest
new file mode 100644
index 000000000000..d7cb12721aef
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/Manifest
@@ -0,0 +1,4 @@
+DIST amazon-ecr-credential-helper-0.9.0-deps.tar.xz 1473848 BLAKE2B 2c16b90951eb62d272b770acf83cd317aa04823277bdce858e4a2741122750199e761cfaaf2a5e477c5ff58209d4a656790a65473400edd1086559dc24ce7c8d SHA512 9830c4eb4cd2fe80a317a09f6bbad0a40493233a49f40d382fff50c438632762f98f23cb4f16340848ae5b67c0b9d3bf569250a1077107e1ceee4afcb83bb4f9
+DIST amazon-ecr-credential-helper-0.9.0.tar.gz 1934543 BLAKE2B 75a247fa8ba395de2274fcef45344ecf9918e032ce365a00cadde17f6f306197729fc77959306ccd11ddfb02272749f42b3f15e587e0eec4772576eb0a84c183 SHA512 354be080bbe83065191efc7c2814cae739944d9405f6472ca99f2a2b00365689ef33361dc1da6ae2e816e6544beb7f8947352752568736382bfb4d976cac7a74
+EBUILD amazon-ecr-credential-helper-0.9.0.ebuild 770 BLAKE2B 7bfdaaee09426b62eb89e4a5337d9ea6c4aa8ff7abc74f66394f88918e2dcd5d1ae1035a7f72c6ab72e7bdd2da717d8e3a85ea8c115907d4ec3407f5571afa51 SHA512 bde8c3eecf00f8ea2e80ffa5a101f755713a45db88bdf50c98d8bcec10e5684c6658fa1ebfcdb2a65916ad775a9a3bed6cbe5c585a889c093489a4717c6fe5bb
+MISC metadata.xml 456 BLAKE2B e531fbcef503889e222e7c8a2732f8079d39030bac2d48c27b853db905a585f7e54cfa1e73abe0546b640475d11a0dab0701d0bb1203f839960373e0c6cabf5d SHA512 a9d4fd8de48fe7c3bebf96b3133ce5cd51ab806947fb3036d766687726c14b84067771e304aa76f1ead0b6d4de4c0e34d481826bcd76a95e96064f3a0aab1a87
diff --git a/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.9.0.ebuild b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.9.0.ebuild
new file mode 100644
index 000000000000..5cab9a842201
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Automatically gets credentials for Amazon ECR on docker push/docker pull"
+HOMEPAGE="https://github.com/awslabs/amazon-ecr-credential-helper"
+SRC_URI="https://github.com/awslabs/amazon-ecr-credential-helper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~arthurzam/distfiles/app-containers/${PN}/${P}-deps.tar.xz"
+S=${WORKDIR}/${P}/ecr-login
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build ./cli/docker-credential-ecr-login
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin docker-credential-ecr-login
+ doman ../docs/docker-credential-ecr-login.1
+ dodoc ../README.md
+}
diff --git a/app-containers/amazon-ecr-credential-helper/metadata.xml b/app-containers/amazon-ecr-credential-helper/metadata.xml
new file mode 100644
index 000000000000..39b215f184f7
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">awslabs/amazon-ecr-credential-helper</remote-id>
+ <changelog>https://github.com/awslabs/amazon-ecr-credential-helper/blob/main/CHANGELOG.md</changelog>
+ </upstream>
+</pkgmetadata>