summaryrefslogtreecommitdiff
path: root/app-containers/crun/crun-1.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/crun/crun-1.11.2.ebuild')
-rw-r--r--app-containers/crun/crun-1.11.2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-containers/crun/crun-1.11.2.ebuild b/app-containers/crun/crun-1.11.2.ebuild
index 91bb5534e6c3..029066f58826 100644
--- a/app-containers/crun/crun-1.11.2.ebuild
+++ b/app-containers/crun/crun-1.11.2.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
src_configure() {
local myeconfargs=(
+ --cache-file="${S}"/config.cache
$(use_enable bpf)
$(use_enable caps)
$(use_enable criu)
@@ -57,6 +58,14 @@ src_compile() {
emake crun
}
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+# due to this we disable most of the core test suite by unsetting PYTHON_TESTS
+src_test() {
+ emake check PYTHON_TESTS=
+}
+
src_install() {
emake "DESTDIR=${D}" install-exec
doman crun.1
@@ -65,11 +74,3 @@ src_install() {
einfo "Cleaning up .la files"
find "${ED}" -name '*.la' -delete || die
}
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-# due to this we disable most of the core test suite by unsetting PYTHON_TESTS
-src_test() {
- emake check PYTHON_TESTS=
-}