summaryrefslogtreecommitdiff
path: root/app-containers/lxd/lxd-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/lxd/lxd-5.0.1.ebuild')
-rw-r--r--app-containers/lxd/lxd-5.0.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-containers/lxd/lxd-5.0.1.ebuild b/app-containers/lxd/lxd-5.0.1.ebuild
index b761f3d0f2b8..3d6d3f2abe58 100644
--- a/app-containers/lxd/lxd-5.0.1.ebuild
+++ b/app-containers/lxd/lxd-5.0.1.ebuild
@@ -125,7 +125,7 @@ src_compile() {
go install -v -x "${S}/${k}" || die "failed compiling ${k}"
done
- go install -v -x -tags libsqlite3 ${S}/lxd || die "Failed to build the daemon"
+ go install -v -x -tags libsqlite3 "${S}"/lxd || die "Failed to build the daemon"
# Needs to be built statically
CGO_ENABLED=0 go install -v -tags netgo "${S}"/lxd-migrate
@@ -177,4 +177,14 @@ pkg_postinst() {
optfeature "zfs storage backend" sys-fs/zfs
elog
elog "Be sure to add your local user to the lxd group."
+
+ if [[ -n ${REPLACING_VERSIONS} ]] && has_version app-emulation/qemu[spice,usbredir,virtfs]; then
+ ewarn ""
+ ewarn "You're updating from <5.0.1. Due to incompatible API updates in the lxd-agent"
+ ewarn "product, you'll have to restart any running virtual machines before they work"
+ ewarn "properly."
+ ewarn ""
+ ewarn "Run: 'lxc restart your-vm' after the update for your vm's managed by lxd."
+ ewarn ""
+ fi
}