summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin7223 -> 7220 bytes
-rw-r--r--app-containers/grype/Manifest1
-rw-r--r--app-containers/grype/grype-0.44.0-r1.ebuild33
-rw-r--r--app-containers/syft/Manifest1
-rw-r--r--app-containers/syft/syft-0.52.0-r1.ebuild34
5 files changed, 69 insertions, 0 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index a1c58b03c78a..24797757dd9c 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index cd6aa875d57b..525bd33978df 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -1,4 +1,5 @@
DIST grype-0.44.0-deps.tar.xz 641743984 BLAKE2B f30557d75628f84dff70ca4272555c7c3577bfe572c9ba16b0e78bc472732d5e82e734ed1ba4dfed59dbb86dc6a788d1379824e7b31bcdd148c5dff43f87e011 SHA512 de46c03f35f70353f0250b77364252316c48f70c1c4549f5d2a680062faee0305c7190906087e94d927333c4fae76de3c3b16046e3f3dc089013b66e132a2ff9
DIST grype-0.44.0.tar.gz 1071804 BLAKE2B 2334ec9b9c04dfc03dbd280725a55bb6cdcd4569431eeb94abe799c75be08ff5164446cba7e97e3dc0ed8dcc10ba4bc8f70edecf9766cdc63e91b3dd420de391 SHA512 7573d03c2e0cbabb6ae3a91ebaa65848a7b43fc3624416f6c52a001acf6cfc839bce806e8e914c29bc2d0fc1aadd9b568ffc21d5a60bd9c05905e0185d7bdcd3
+EBUILD grype-0.44.0-r1.ebuild 1018 BLAKE2B 6642d3ab6abee69d6b6467469a4a3a8a9a625db99509c318fed928a223dc75bd012699f0189818603499ea39ff159d5ff273b344f0960471f6fe391bbc66919e SHA512 8f7965f641e810a222dc3962da5f0da8e6730258093f3df6add5a4dbd93c642cf78e05a31435fda0460a6ab8bcc3d878d6522fed8b161485a0882e391b59e8d5
EBUILD grype-0.44.0.ebuild 511 BLAKE2B c1cf14d31e5d8bf842ce01048f0f3e9813e19e16d39222b3ae485134418587dbef88eaa5122ab37e693b635e0336835449aeea430df8fda7dac8b116e72b5c4c SHA512 b5f79ba354cc9db9dccff1c3e5b87be41924d5fc07df36b85a4fa20e65b04f9b473d0742620ba9238fe92644a8ff2a67c16e62708e6fbf11d690f205e8319dec
MISC metadata.xml 243 BLAKE2B 63665ae2020bc799fa6ebd6e1fca6755be6498803fdbc17cc630f9f4ffa03fbd46a9ad396e70adc3bc1c32b0a746fe4bab1c6291f32e68e636251207bca9e95c SHA512 78eab20831018fcf4957171a83aaaca9ced53380e01f083c07450c30fa1adfc02dd50ff2fa9f491dd62802f6e779264add1c47a09ade0a35cda558c1d5529ad0
diff --git a/app-containers/grype/grype-0.44.0-r1.ebuild b/app-containers/grype/grype-0.44.0-r1.ebuild
new file mode 100644
index 000000000000..868972a69ab6
--- /dev/null
+++ b/app-containers/grype/grype-0.44.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=a6ec8f11be5fdc116dc7bbfebdc03bfc13cd2005
+SYFT_VERSION=0.52.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index 8d08c74df108..7fb3be61838b 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -1,4 +1,5 @@
DIST syft-0.52.0-deps.tar.xz 962322444 BLAKE2B 696dd14adf54c8ab51cc91d22028ce0ace3b6a5835fb8c3ce6d26080f0ce75d2a9ca332f2275a71706a2152519b01a71577827ac63c12ffb87ad1605ffd18b28 SHA512 b6897a12b8a15c8c2b4672e93ca03fe26a182ee87e48ac4bdd26057f544a6a45aa5ce6317a38e157b99a70830d4a0241f8b4cb15f8fffccaf195ac4c4ff64cd8
DIST syft-0.52.0.tar.gz 3726656 BLAKE2B de8492adde3bef944a9b853990ba5909aa14ccc223f42833fa2a49d1bd5772455bd3ab9ac3a8886b353dc79c6e93338e43e9c448623bd31c422155e0adb1f276 SHA512 2ffaaa154546061d1d61bf8f0b3d5cf10282dbbb08876cc9e87777a23efdba1fd462c395ee4cf14d334f49ae4575e2db5fe8b5fbe7439dd24ff22ec8efeb6501
+EBUILD syft-0.52.0-r1.ebuild 1017 BLAKE2B a4b66cc02469d967489b9f61af5712ba7475e11e8109256af241b4606a6762a9680d29b0d206bd4398851fa9ae61a99a1fa7f93b5947fc6a9fb7f293dd96adb8 SHA512 d79f5db1f6d39a494545defe4ddd386de74f53234ad2dadbfd7ad0e2cf3faadb93cd0fea2b3aca18ae703fead219b57be3b89baf1e90e92e55992b5eb94f314f
EBUILD syft-0.52.0.ebuild 531 BLAKE2B cc3863fc3db089b85095646c7de8eb1b8a74cbdd72e7e7eedd57e3082443ee2ac685a87094336530e23d9097fbb7ade8699fc54e98f0910c6a33bb1d935ef166 SHA512 c248c0cda550e2479736a22dd25777ce6cd11d97c4468db14a2b43f57e78c6780c957a0502e461af41b941c5056c947bc5026e7f2aa50420a7bffe82302c3356
MISC metadata.xml 243 BLAKE2B 63665ae2020bc799fa6ebd6e1fca6755be6498803fdbc17cc630f9f4ffa03fbd46a9ad396e70adc3bc1c32b0a746fe4bab1c6291f32e68e636251207bca9e95c SHA512 78eab20831018fcf4957171a83aaaca9ced53380e01f083c07450c30fa1adfc02dd50ff2fa9f491dd62802f6e779264add1c47a09ade0a35cda558c1d5529ad0
diff --git a/app-containers/syft/syft-0.52.0-r1.ebuild b/app-containers/syft/syft-0.52.0-r1.ebuild
new file mode 100644
index 000000000000..78e4ff1e79aa
--- /dev/null
+++ b/app-containers/syft/syft-0.52.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=ba9adb17ebb510a2a3bd2b641738b1d9235e1f3e
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}