summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild b/app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild
new file mode 100644
index 000000000000..b6e0adc64e85
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-2.11.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="amd64 ~arm64 ~riscv x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot-apache/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# See module setup.py for dependencies
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}