summaryrefslogtreecommitdiff
path: root/app-crypt/cfssl/cfssl-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/cfssl/cfssl-1.3.2.ebuild')
-rw-r--r--app-crypt/cfssl/cfssl-1.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/cfssl/cfssl-1.3.2.ebuild b/app-crypt/cfssl/cfssl-1.3.2.ebuild
new file mode 100644
index 000000000000..6b1f640b3abc
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${S}" go install -v github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}