summaryrefslogtreecommitdiff
path: root/app-crypt/ckpass/ckpass-0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ckpass/ckpass-0.2-r2.ebuild')
-rw-r--r--app-crypt/ckpass/ckpass-0.2-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/ckpass/ckpass-0.2-r2.ebuild b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
new file mode 100644
index 000000000000..48fc5954525f
--- /dev/null
+++ b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="ncurses based password database client compatible with KeePass 1.x databases"
+HOMEPAGE="http://ckpass.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-libs/libkpass-6"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-implicit-function-declaration.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}