summaryrefslogtreecommitdiff
path: root/app-crypt/kbfs/kbfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/kbfs/kbfs-9999.ebuild')
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
index b084faeb8f15..e3870b505ace 100644
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit git-r3
+inherit git-r3 systemd
DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
@@ -14,10 +14,7 @@ SLOT="0"
KEYWORDS=""
IUSE="git"
-DEPEND="
- >=dev-lang/go-1.6:0
- >=app-crypt/keybase-1.0.17
- "
+DEPEND=">=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
@@ -49,4 +46,5 @@ src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
}