summaryrefslogtreecommitdiff
path: root/app-crypt/libscrypt/libscrypt-1.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libscrypt/libscrypt-1.21.ebuild')
-rw-r--r--app-crypt/libscrypt/libscrypt-1.21.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/libscrypt/libscrypt-1.21.ebuild b/app-crypt/libscrypt/libscrypt-1.21.ebuild
new file mode 100644
index 000000000000..62491faa8ab2
--- /dev/null
+++ b/app-crypt/libscrypt/libscrypt-1.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shared library to impliment the scrypt algorithm"
+HOMEPAGE="https://github.com/technion/libscrypt"
+SRC_URI="https://github.com/technion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+pkg_setup() {
+ export LIBDIR=${PREFIX}/$(get_libdir)
+ export CFLAGS_EXTRA="${CFLAGS}"
+ export LDFLAGS_EXTRA="${LDFLAGS}"
+ export PREFIX=/usr
+ unset CFLAGS
+ unset LDFLAGS
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC)
+}