summaryrefslogtreecommitdiff
path: root/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/mhash/mhash-0.9.9.9-r2.ebuild')
-rw-r--r--app-crypt/mhash/mhash-0.9.9.9-r2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild b/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
index 300d6c81abea..17078b15f18e 100644
--- a/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit ltprune
+EAPI=7
DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -13,8 +12,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
-RDEPEND=""
-DEPEND="dev-lang/perl" # pod2html
+BDEPEND="dev-lang/perl" # pod2html
PATCHES=(
"${FILESDIR}/${PN}-0.9.9-fix-mem-leak.patch"
@@ -39,7 +37,7 @@ src_prepare() {
default
sed -i \
-e 's/--netscape//' \
- "${S}"/doc/Makefile.in
+ "${S}"/doc/Makefile.in || die
}
src_configure() {
@@ -56,5 +54,5 @@ src_compile() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
}