summaryrefslogtreecommitdiff
path: root/app-crypt/nasty/nasty-0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/nasty/nasty-0.6-r1.ebuild')
-rw-r--r--app-crypt/nasty/nasty-0.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/nasty/nasty-0.6-r1.ebuild b/app-crypt/nasty/nasty-0.6-r1.ebuild
new file mode 100644
index 000000000000..8cfa34f4d007
--- /dev/null
+++ b/app-crypt/nasty/nasty-0.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
+HOMEPAGE="http://www.vanheusden.com/nasty/"
+SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-crypt/gpgme"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ readme.txt
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-flags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG=
+}
+
+src_install() {
+ einstalldocs
+ dobin nasty
+}