summaryrefslogtreecommitdiff
path: root/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/osslsigncode/osslsigncode-1.4.ebuild')
-rw-r--r--app-crypt/osslsigncode/osslsigncode-1.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/osslsigncode/osslsigncode-1.4.ebuild b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
new file mode 100644
index 000000000000..43d60cc9620a
--- /dev/null
+++ b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://sourceforge.net/projects/osslsigncode"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_with curl)
+}