summaryrefslogtreecommitdiff
path: root/app-crypt/p11-kit/p11-kit-0.25.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/p11-kit/p11-kit-0.25.0.ebuild')
-rw-r--r--app-crypt/p11-kit/p11-kit-0.25.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-crypt/p11-kit/p11-kit-0.25.0.ebuild b/app-crypt/p11-kit/p11-kit-0.25.0.ebuild
deleted file mode 100644
index 46287250efa9..000000000000
--- a/app-crypt/p11-kit/p11-kit-0.25.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 meson-multilib
-
-DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
-HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
-SRC_URI="https://github.com/p11-glue/p11-kit/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+libffi gtk-doc nls systemd test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-misc/ca-certificates
- >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}]
- libffi? ( dev-libs/libffi:=[${MULTILIB_USEDEP}] )
- systemd? ( sys-apps/systemd:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- gtk-doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
-"
-
-multilib_src_configure() {
- # Disable unsafe tests, bug#502088
- export FAKED_MODE=1
-
- local emesonargs=(
- -Dbashcompdir="$(get_bashcompdir)"
- -Dtrust_module=enabled
- -Dtrust_paths="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
- $(meson_feature libffi)
- $(meson_use nls)
- $(meson_use test)
- $(meson_native_use_bool gtk-doc gtk_doc)
- $(meson_native_true man)
- $(meson_native_use_feature systemd)
- )
-
- meson_src_configure
-}