summaryrefslogtreecommitdiff
path: root/app-crypt/pius
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/pius')
-rw-r--r--app-crypt/pius/Manifest3
-rw-r--r--app-crypt/pius/metadata.xml18
-rw-r--r--app-crypt/pius/pius-2.2.4.ebuild20
3 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/pius/Manifest b/app-crypt/pius/Manifest
new file mode 100644
index 000000000000..3b42343f0764
--- /dev/null
+++ b/app-crypt/pius/Manifest
@@ -0,0 +1,3 @@
+DIST pius-2.2.4.tar.bz2 40578 BLAKE2B e7989631813658ff888c72b825269482ff33296abf0b9780ecb24df4628c499087a7591372ef96449b4899b1bcd730b0c75411bcd3c8839c57d3d4b5de374862 SHA512 3a178d30d98d0ed7ddf6819578a54ccfb9719f77c1f6385e3b254e28cd890817f328685c02cc464d4d592961c28ba314ca3175056b412dcdb301b851d874eb60
+EBUILD pius-2.2.4.ebuild 491 BLAKE2B 61ece77e1bb6e0112561fa0cd104e855e0cbdfdbe2880d99454ffa8c44848dce2cfa7e162622ff86c38314c8bf2bcd1ef25ae62a744486aa68677302dfcb9906 SHA512 562dceeaa4fdaa16cbaa34f5e86db4c827d713048f3799746a988f9b10530e0b5a3431435d419aeb0485ac7da98f5b29eb5193b550de74a0ef2e94e1fb86e34b
+MISC metadata.xml 689 BLAKE2B 40ea626d106920eaf8d0e2ae15637e54f9f81933c222b058834f69e9ec1cef52c634fb176f1a6b8d48f4c0f664092cfcf2ee1f58bdec84f591410323eb0a4914 SHA512 77e117dc545213fdc376935a62d22a0b1db1aaa05fc5fc6ae83e0ffba49693411a451485c519c1bf1a17a829833a90d78472754600ed4dd5f779a772cc480218
diff --git a/app-crypt/pius/metadata.xml b/app-crypt/pius/metadata.xml
new file mode 100644
index 000000000000..168be220f27a
--- /dev/null
+++ b/app-crypt/pius/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <longdescription lang="en">
+ The PGP Individual UID Signer (PIUS) is a tool for individually
+ signing all of the UIDs on a set of keys and encrypt-emailing each
+ one to it's respective email address. This drastically reduces the time
+ and errors involved in signing keys after a keysigning party.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pgpius</remote-id>
+ <remote-id type="github">jaymzh/pius</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/pius/pius-2.2.4.ebuild b/app-crypt/pius/pius-2.2.4.ebuild
new file mode 100644
index 000000000000..927947b3642a
--- /dev/null
+++ b/app-crypt/pius/pius-2.2.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for signing and email all UIDs on a set of PGP keys"
+HOMEPAGE="https://www.phildev.net/pius/"
+SRC_URI="https://github.com/jaymzh/pius/releases/download/v${PV}/pius-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-crypt/gnupg-2.0.0"
+RDEPEND="${DEPEND}
+ dev-lang/perl"