summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild')
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
index f8986d88dc98..9f3fd54be541 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info tmpfiles udev
+inherit autotools linux-info tmpfiles udev
DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
@@ -17,16 +17,16 @@ IUSE="doc +fapi gcrypt +openssl static-libs test"
RESTRICT="!test? ( test )"
REQUIRED_USE="^^ ( gcrypt openssl )
- fapi ( !gcrypt )"
+ fapi? ( openssl !gcrypt )"
RDEPEND="acct-group/tss
- acct-user/tss
- fapi? (
+ acct-user/tss
+ fapi? (
dev-libs/json-c
- net-misc/curl
- )
- gcrypt? ( dev-libs/libgcrypt:0= )
- openssl? ( dev-libs/openssl:0= )"
+ net-misc/curl
+ )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ openssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}
test? ( dev-util/cmocka )"
BDEPEND="virtual/pkgconfig
@@ -34,7 +34,8 @@ BDEPEND="virtual/pkgconfig
PATCHES=(
"${FILESDIR}/${PN}-2.4.0-fix-tmpfiles-path.patch"
-)
+ "${FILESDIR}/${PN}-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch"
+ )
pkg_setup() {
local CONFIG_CHECK=" \
@@ -44,6 +45,11 @@ pkg_setup() {
kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable doc doxygen-doc) \
@@ -57,7 +63,7 @@ src_configure() {
--with-runstatedir=/run \
--with-udevrulesdir="$(get_udevdir)/rules.d" \
--with-udevrulesprefix=60- \
- --with-sysusersdir="/usr/lib/sysusers.d"
+ --with-sysusersdir="/usr/lib/sysusers.d" \
--with-tmpfilesdir="/usr/lib/tmpfiles.d"
}