summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin23948 -> 23939 bytes
-rw-r--r--app-crypt/gcr/Manifest2
-rw-r--r--app-crypt/gcr/gcr-3.41.1.ebuild84
-rw-r--r--app-crypt/kbfs/Manifest6
-rw-r--r--app-crypt/kbfs/kbfs-2.10.1.ebuild51
-rw-r--r--app-crypt/kbfs/kbfs-2.6.0.ebuild51
-rw-r--r--app-crypt/kbfs/kbfs-2.8.0.ebuild51
7 files changed, 86 insertions, 159 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 1f1c8eb765d3..903786819060 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/gcr/Manifest b/app-crypt/gcr/Manifest
index 7a0d67ecc80d..5f9b5c421589 100644
--- a/app-crypt/gcr/Manifest
+++ b/app-crypt/gcr/Manifest
@@ -2,5 +2,7 @@ AUX 3.38.0-optional-vapi.patch 2278 BLAKE2B 7011aec6831b9488ba19efd41b6f3772af10
AUX gcr-3.40.0-meson-0.61-build.patch 1634 BLAKE2B 99593b9614831a4a2a47ff4890d1f3a92ceb3fe861bdcd3fa748b51b19645196392e6482dea8bb4330bd39484ecddb74dd8d6dea17beb26f87bb05727b506ee3 SHA512 343c02730611ac4792e572dbfbd14bee5525c9ac00f739b12ce1711b059f00a3c9869e60db33e0dd7010b78dd4bb5309c1cecb29052d97fe68429d0118b98ecc
AUX gcr-3.41.0-Unbreak-build-without-systemd.patch 766 BLAKE2B 005ba225708f0a676be937e809511e7e478ec16610d1bf068ca9e01c210e3d2567e8a3cdbf513c51b3cff57ad0834526e22f17490432dd7c6fa80a16dec4351a SHA512 2192e3556fb134ebbf0bab7e23f6d3b12da601286532e8a5c8fa52d69ac31a1ec3d8e941ff4d5d91737001306aa594996de58449498b2c93d07f53dec83a8401
DIST gcr-3.41.0.tar.xz 1039744 BLAKE2B c646a04168310051d5b582a9d2f7ab9da89eef095e856e56b8d730600debead051ad8bb40eddb7457b1be2be3e092227dd886f647258a9c6a81d4bab728245f7 SHA512 455acc40ed77feeb35f9845b00229f468b322b7eda0b1b5abb0153f0a6ba29f3d0364df22225143f4caf130254a1258b3c7f934370e5142f2f64e1c3084b6f6e
+DIST gcr-3.41.1.tar.xz 1030368 BLAKE2B 9d254b7f2ad864c45200e58b685db97c1ffbc83d29ba8cbda94d30ec565aa3dc5a2535305dc63b3264131b68ec9e48f37ac30d5ba08d0ce156f3b6091cd62dc1 SHA512 dd70d41636ede863d05824b26823a8f572902f7a9b6f09b0c70586ef0d4c046864e6956130b9231850a515a9fbfcd56faf20354c1cf8f697f005827c048a2325
EBUILD gcr-3.41.0.ebuild 2005 BLAKE2B 82b8133aac42ef6a0e17b431b4509043280eba6bccbf3df3a39901a7b8921dc54c01541f6cd943e8a88ac3c55071c9115337a2504387bca72d5b9735c2aea71b SHA512 596f577056f7dff17eded2334a6a44d0c94d26faca0aca047d4cd568b4bed6f3d8ea90ba93ddca2972211cdf80028648aa16fc36f24c27b803b2faafa3558345
+EBUILD gcr-3.41.1.ebuild 1865 BLAKE2B 40f338fbde316ff23562a23646d0f88a4fd4841665fb68066c1c92d97421441049b86a641c38a47cdc1d15bf68f6fd1dc7610c8fb473b238bfc564643c336d8c SHA512 8d229b9a212adc9ca61ac6e89b51e98d1bba5ac280fd6f3406c60e02bc8d513460d1c8c19fb77dfa9a4c0a0c103f3d88e360afb0df809561ae69034d8453fd18
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/app-crypt/gcr/gcr-3.41.1.ebuild b/app-crypt/gcr/gcr-3.41.1.ebuild
new file mode 100644
index 000000000000..53971669534e
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.41.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gcr"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-base-3 and co
+
+IUSE="gtk gtk-doc +introspection systemd test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=app-crypt/p11-kit-0.19.0
+ >=app-crypt/libsecret-0.20
+ systemd? ( sys-apps/systemd:= )
+ gtk? ( >=x11-libs/gtk+-3.22:3[introspection?] )
+ >=sys-apps/dbus-1
+ introspection? ( >=dev-libs/gobject-introspection-1.58:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="app-crypt/gnupg"
+BDEPEND="
+ ${PYTHON_DEPS}
+ gtk? ( dev-libs/libxml2:2 )
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ test? ( app-crypt/gnupg )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.38.0-optional-vapi.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use gtk)
+ $(meson_use gtk-doc gtk_doc)
+ -Dgpg_path="${EPREFIX}"/usr/bin/gpg
+ -Dssh_agent=true
+ $(meson_feature systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-crypt/kbfs/Manifest b/app-crypt/kbfs/Manifest
index e61025b450fd..27f9a6ad6edd 100644
--- a/app-crypt/kbfs/Manifest
+++ b/app-crypt/kbfs/Manifest
@@ -1,10 +1,4 @@
-DIST kbfs-2.10.1.tar.gz 4471525 BLAKE2B 79a1046a6d225ab790081e2ec0aa057c8aab9c3c1fd0fe9832769b01f2e92137aa3b6424c303b736dbc6142917aecbb32c54d98111b42be80e66ee459524c7f2 SHA512 66b07a07c4b4734465d8ea8eccf3b1d05c0c3ba8792161ed3fd8ed9eaccb43d51cf5ef44c8c44fca4a22ab2b360093f1801d9eb77904d2aa917d0a76026fffa9
DIST kbfs-2.11.0.tar.gz 4520872 BLAKE2B 4472360205f42f59bc18f64634b4e10f38f532db262de38260a459faf0d76b9f805fb3d5e12d21afecbd51a980e63c68cc2be47b4e5ab597b7b0bfdd491dd54d SHA512 f735f7fc1c958eabcb38933f19edeba0cd3854e3d5a2030c6e4301c9cea714c432993e099b2199060e1275982755f60728545e71151c5796eb9be4978790e2f5
-DIST kbfs-2.6.0.tar.gz 5836566 BLAKE2B 14ca1fa35d01330ad51c5ca735bea059dc4f5be10298f36d2a7bd10ab5cfe2a399104dbade2da58ea3e0e77ef1e24f0644b751e7f06b91e9f4360514aaa7f6df SHA512 f636f6d01fa12e63930be7fa2d0cd919c37e68820bd602af6a54703a64759e475c5e19e29bf60b94d02dd9db188709c9ecd4da7abd05af7880fdf5e94a8d3590
-DIST kbfs-2.8.0.tar.gz 4459997 BLAKE2B b361ae343ab5fada7f9edac8c5083173dca103362b6e0688df069fbc0bf7dbb0eab6779259bd5c1038c542d7f51b68259404aa24c797da5c3aee6fab9fc4dab1 SHA512 892b7c51f52ca129145f10932e23c22f0f7003ea8662d26939d4f9e72cd8296fc5a66516dc7a3135fdc1cb96b1d02160c0f1dd32a4a6fe13ddcd4750eac9b8fc
-EBUILD kbfs-2.10.1.ebuild 1256 BLAKE2B 87285240aaf1f9685a6ea12ebe8db704d294cc923f23b760873fba48ab22795a915bebca9913c6a369fc10c67f6aee4fa6354902889dd8c0fb414212eb61d1be SHA512 5759fea9cacb3a60a1e9eb4934cd35beba52c08f7d6889bb8cacd4075bb977c7d8694292158a9a58493c88173aae498d8579188ed72020a7d3f64f7e61b8a226
EBUILD kbfs-2.11.0-r1.ebuild 1259 BLAKE2B b51c8b0bf6ef148d8febd80b4ecf6c8b786ba4af1026871872de53a49e0b3a59919873b80185721a379f959fba9e066a675dc0ef2da945c81d142cde7210b5ea SHA512 5caa35185d689b962ebd6a029da141358680ecb4c3a5892ec1163f9c2c1903f79ec9ef9c8ba568a23cfea6f517490f6f0f416e9947be97fb4a1f86ef31adcd32
-EBUILD kbfs-2.6.0.ebuild 1259 BLAKE2B 2245307f05dfceab185249d48b8ff5db84c5f1f052bf9068336677f1803ebf312ccfdf5ee3be92696e492b4338ef7a3522a47e5c5077908c6665428db1863c19 SHA512 9f028136347e29dfa3d87406fc7d352a2e4c051536c741063cc83650fc23f643288b5b671891377cf9923ac9f30c927979127a27a83fe9c6340515072621741c
-EBUILD kbfs-2.8.0.ebuild 1256 BLAKE2B 87285240aaf1f9685a6ea12ebe8db704d294cc923f23b760873fba48ab22795a915bebca9913c6a369fc10c67f6aee4fa6354902889dd8c0fb414212eb61d1be SHA512 5759fea9cacb3a60a1e9eb4934cd35beba52c08f7d6889bb8cacd4075bb977c7d8694292158a9a58493c88173aae498d8579188ed72020a7d3f64f7e61b8a226
EBUILD kbfs-9999.ebuild 1228 BLAKE2B 71eae998751b73148cc81afec289822651148c90f41f2089516cf46745d505c59a1baf1881444536b9d18a5fdae2320f248334f82d0ce6092088e0e4684c2d85 SHA512 f24901898bb35d84978463922b441b1c85628b170d8b646d576470d7bc1bbac5cc5086af31a7e3c4c020a205c87c3e29fb62e44959fdd50145f8640795cc1624
MISC metadata.xml 335 BLAKE2B 2f2f44f5d04514f5526d07b851ee2a4b17890eb36ddcf823c95a57c1a1be84dd4c0d43bd11ecaefd797873282c14df161ea44bdb845f65735809720f6e9044ac SHA512 0c133b9a64d67ed69aac9b4b9a6489156d37dcfa5541c8345d110569b94bc8a3044cb3adcf38675ff6b9faf82b34355664351295b69e92ad15aca0d2fe638616
diff --git a/app-crypt/kbfs/kbfs-2.10.1.ebuild b/app-crypt/kbfs/kbfs-2.10.1.ebuild
deleted file mode 100644
index f6dfded5dc62..000000000000
--- a/app-crypt/kbfs/kbfs-2.10.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-build systemd
-
-DESCRIPTION="Keybase Filesystem (KBFS)"
-HOMEPAGE="https://keybase.io/docs/kbfs"
-SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-crypt/gnupg
- sys-fs/fuse
- "
-
-src_unpack() {
- unpack "${P}.tar.gz"
- mkdir -vp "${S}/src/github.com/keybase" || die
- ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
-}
-
-src_compile() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/redirector" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
- golang-build_src_compile
-}
-
-src_test() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- golang-build_src_test
-}
-
-src_install() {
- dobin "${T}/kbfsfuse"
- dobin "${T}/git-remote-keybase"
- dobin "${T}/keybase-redirector"
- systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
-}
diff --git a/app-crypt/kbfs/kbfs-2.6.0.ebuild b/app-crypt/kbfs/kbfs-2.6.0.ebuild
deleted file mode 100644
index 41a15fe68057..000000000000
--- a/app-crypt/kbfs/kbfs-2.6.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-build systemd
-
-DESCRIPTION="Keybase Filesystem (KBFS)"
-HOMEPAGE="https://keybase.io/docs/kbfs"
-SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-crypt/gnupg
- sys-fs/fuse
- "
-
-src_unpack() {
- unpack "${P}.tar.gz"
- mkdir -vp "${S}/src/github.com/keybase" || die
- ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
-}
-
-src_compile() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/redirector" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
- golang-build_src_compile
-}
-
-src_test() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- golang-build_src_test
-}
-
-src_install() {
- dobin "${T}/kbfsfuse"
- dobin "${T}/git-remote-keybase"
- dobin "${T}/keybase-redirector"
- systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
-}
diff --git a/app-crypt/kbfs/kbfs-2.8.0.ebuild b/app-crypt/kbfs/kbfs-2.8.0.ebuild
deleted file mode 100644
index f6dfded5dc62..000000000000
--- a/app-crypt/kbfs/kbfs-2.8.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-build systemd
-
-DESCRIPTION="Keybase Filesystem (KBFS)"
-HOMEPAGE="https://keybase.io/docs/kbfs"
-SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-crypt/gnupg
- sys-fs/fuse
- "
-
-src_unpack() {
- unpack "${P}.tar.gz"
- mkdir -vp "${S}/src/github.com/keybase" || die
- ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
-}
-
-src_compile() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/redirector" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
- golang-build_src_compile
-}
-
-src_test() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- golang-build_src_test
-}
-
-src_install() {
- dobin "${T}/kbfsfuse"
- dobin "${T}/git-remote-keybase"
- dobin "${T}/keybase-redirector"
- systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
-}