summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild')
-rw-r--r--app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild b/app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild
new file mode 100644
index 000000000000..b8a806db801e
--- /dev/null
+++ b/app-dicts/myspell-nb/myspell-nb-2.0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "nb_NO.aff"
+ "nb_NO.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nb_NO.dic"
+)
+
+MYSPELL_THES=(
+ "th_nb_NO_v2.dat"
+ "th_nb_NO_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Norwegian dictionaries for myspell/hunspell"
+HOMEPAGE="http://spell-norwegian.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/2357/no_NO-pack2-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ myspell-r2_src_unpack
+
+ for i in *.zip; do
+ unzip ${i} || die
+ done
+}