summaryrefslogtreecommitdiff
path: root/app-doc/devmanual
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/devmanual')
-rw-r--r--app-doc/devmanual/Manifest4
-rw-r--r--app-doc/devmanual/devmanual-0_pre20141116.ebuild66
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild66
-rw-r--r--app-doc/devmanual/metadata.xml11
4 files changed, 147 insertions, 0 deletions
diff --git a/app-doc/devmanual/Manifest b/app-doc/devmanual/Manifest
new file mode 100644
index 000000000000..d4e1123ae1a7
--- /dev/null
+++ b/app-doc/devmanual/Manifest
@@ -0,0 +1,4 @@
+DIST devmanual-0_pre20141116.tar.gz 169936 BLAKE2B 9b01004750b9fce226fa6a965292d3ffaff0923f877da611743e39ee19077ea7fe0d21ff138853d3f79e4d4941026c30fcabf63c8903572ed7ba5d50d32c8dd5 SHA512 6af3f9a262bdb2ceb61ab195691dff4a850b22e8d1226e20ae3257c566b6cc913f756c8b90a40e8aa78b1242e78d24c4209a1d9cdb0706ae9b64c653544a028f
+EBUILD devmanual-0_pre20141116.ebuild 1773 BLAKE2B ca879efa95086f57a5b648b0e8c093cbef4e3f6aa74c41492ba4559c1f2180157006a1212f911087f4a31cf0159e3bf26a638ec963030a1bee2f04c3eaa46995 SHA512 8ff92699f5e975df3890363334286b023ce3d7d552ab001b47513cbe7615c3d4e0fd54050ca4b405e7e4689fda96782e56eea80a7d5cc0545fff3fcc7c18afd2
+EBUILD devmanual-9999.ebuild 1773 BLAKE2B ca879efa95086f57a5b648b0e8c093cbef4e3f6aa74c41492ba4559c1f2180157006a1212f911087f4a31cf0159e3bf26a638ec963030a1bee2f04c3eaa46995 SHA512 8ff92699f5e975df3890363334286b023ce3d7d552ab001b47513cbe7615c3d4e0fd54050ca4b405e7e4689fda96782e56eea80a7d5cc0545fff3fcc7c18afd2
+MISC metadata.xml 350 BLAKE2B 67b9c910e7db016681e9ef93572a28c154793c672735ae3212c0b103a1fa4c92f738e2286cf970510b2d034e6de433bf315cb36205a734e2515492d89ae05ffd SHA512 0999bf9619d15f407c0744e266704fbbb2e07ee1f7e23f1b422e7f918720efeb977081fbdfbbc623795f3d08b566f94414c9585fbc5c6e2a45c435ffc632d5c4
diff --git a/app-doc/devmanual/devmanual-0_pre20141116.ebuild b/app-doc/devmanual/devmanual-0_pre20141116.ebuild
new file mode 100644
index 000000000000..e891efa24f23
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20141116.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+else
+ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype,svg,png]"
+
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
+src_install() {
+ # clean out XML/XSL before installing
+ find . \( \
+ -iname '*.xml' -o \
+ -iname '*.xsl' -o \
+ -iname '*.svg' \) -delete || die
+ rm -r README.md xsl LICENSE Makefile || die
+
+ local HTML_DOCS=( . )
+ einstalldocs
+
+ einfo "Creating symlink from ${PF} to ${PN} for preserving bookmarks"
+ dosym ${PF} /usr/share/doc/${PN}
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ ${EPREFIX}/usr/share/doc/devmanual/html/index.html"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
new file mode 100644
index 000000000000..e891efa24f23
--- /dev/null
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+else
+ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype,svg,png]"
+
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
+src_install() {
+ # clean out XML/XSL before installing
+ find . \( \
+ -iname '*.xml' -o \
+ -iname '*.xsl' -o \
+ -iname '*.svg' \) -delete || die
+ rm -r README.md xsl LICENSE Makefile || die
+
+ local HTML_DOCS=( . )
+ einstalldocs
+
+ einfo "Creating symlink from ${PF} to ${PN} for preserving bookmarks"
+ dosym ${PF} /usr/share/doc/${PN}
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ ${EPREFIX}/usr/share/doc/devmanual/html/index.html"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}
diff --git a/app-doc/devmanual/metadata.xml b/app-doc/devmanual/metadata.xml
new file mode 100644
index 000000000000..19e224cd84eb
--- /dev/null
+++ b/app-doc/devmanual/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Bugs for the devmanual documentation must be assigned to
+devmanual@gentoo.org
+</description>
+</maintainer>
+</pkgmetadata>