summaryrefslogtreecommitdiff
path: root/app-doc/halibut/halibut-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/halibut/halibut-1.2.ebuild')
-rw-r--r--app-doc/halibut/halibut-1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-doc/halibut/halibut-1.2.ebuild b/app-doc/halibut/halibut-1.2.ebuild
new file mode 100644
index 000000000000..5a7b3c9d44f7
--- /dev/null
+++ b/app-doc/halibut/halibut-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="yet another free document preparation system"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ BUILDDIR="${S}/build" \
+ VERSION="${PV}" \
+ emake || die "make failed"
+ emake -C doc || die "make in doc failed"
+}
+
+DOCS=( doc/halibut.txt )
+HTML_DOCS=(
+ doc/index.html
+ doc/IndexPage.html
+ doc/input.html
+ doc/intro.html
+ doc/licence.html
+ doc/manpage.html
+ doc/output.html
+ doc/running.html
+)
+
+src_install() {
+ dobin build/halibut
+ doman doc/halibut.1
+ doinfo doc/halibut.info
+ einstalldocs
+}