summaryrefslogtreecommitdiff
path: root/app-doc
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/Manifest.gzbin7646 -> 7648 bytes
-rw-r--r--app-doc/zsh-lovers/Manifest2
-rw-r--r--app-doc/zsh-lovers/zsh-lovers-0.11.0.ebuild28
3 files changed, 30 insertions, 0 deletions
diff --git a/app-doc/Manifest.gz b/app-doc/Manifest.gz
index 096415e22b44..ac5cbec89f0c 100644
--- a/app-doc/Manifest.gz
+++ b/app-doc/Manifest.gz
Binary files differ
diff --git a/app-doc/zsh-lovers/Manifest b/app-doc/zsh-lovers/Manifest
index 87c6c9a8259c..8a146aab0cff 100644
--- a/app-doc/zsh-lovers/Manifest
+++ b/app-doc/zsh-lovers/Manifest
@@ -1,3 +1,5 @@
DIST zsh-lovers_0.10.1.tar.xz 26796 BLAKE2B 6ccaf0dda0c7b05131fa1e8f5ccfe29a6e86a503b2b934af704f2d1d15d4826a88b33373b4d83be92cb89c4f52a7665e754982c27bcdb9c582483e8a3d224253 SHA512 b07da3c65a01d3711900ed50b2d0c158be678d5168a0f864c77be52b77e595320e0380173e5b454bdc8b63d28fc437203e6deccdebdfc36b40a0adf2b1a39735
+DIST zsh-lovers_0.11.0.tar.xz 27036 BLAKE2B b4cd65fc112a3f0a915b8dc604d3e89ea1740d61229daa164939b8e420939650f2893d46060ad97bd3fcab65dcb47d967d6b645b6e9c3a48385270d1a1eff628 SHA512 3f3368444e553003369d481d35a273f2e8bf9193a093f31944391053ba3a5428ec1e9bf85cb7940eb52d66c376263adff575cfafbc32d518fc000e86490fb6da
EBUILD zsh-lovers-0.10.1.ebuild 698 BLAKE2B a7e204238c2debd960c8ebf0eeba7aac03be136ef50d54bfb28d8b9799cf5bba7f599297a99c3462e43a0534d64b68af46af1ea3f5c175087dfb23135398aa09 SHA512 fd124aa401bace3754c93331d3fc3fa20ceab93d63f10f392f591407e459494f58b4e85cfeac17c478e0ff4b893deed716b8ac02ae0b68b5b179736312a5d653
+EBUILD zsh-lovers-0.11.0.ebuild 706 BLAKE2B 33cca0c65fc9c61df97323f9efdbf418a512cea9df852846975eae9b0ba01fc9305115abf9465bcb82d81a20a72051d0785c52546db2dadf883c63a6d167e4e9 SHA512 9ce2ad2df81535dfc7e27b3afae11a083f288a2c2f0e2eec3d731908f5df8f7f9ece64cc123de96e59e37f0280ae858eeb6477d21cb5fbccc4926aa5ca06f1f8
MISC metadata.xml 272 BLAKE2B ec4da5250d0654f729e200b17210f865805bb2f29b14515d9c5e75babaea104e0525170bc5a67331694c5a6aa3ab9f6c41ecd45dd4923864a5f2fd10ff2d0637 SHA512 321f06d20486ece9e306e83d22631db2bed7b6d0142247eaf04409f00e3a3e414c3af2b30b93f57c182fe1978360858bb9b49a410b0cf7aeaae070a635b9bca8
diff --git a/app-doc/zsh-lovers/zsh-lovers-0.11.0.ebuild b/app-doc/zsh-lovers/zsh-lovers-0.11.0.ebuild
new file mode 100644
index 000000000000..3804fbbf2b51
--- /dev/null
+++ b/app-doc/zsh-lovers/zsh-lovers-0.11.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tips, tricks and examples for the Z shell"
+HOMEPAGE="
+ https://grml.org/zsh/zsh-lovers.html
+ https://github.com/grml/zsh-lovers
+"
+SRC_URI="https://deb.grml.org/pool/main/z/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="app-text/asciidoc"
+
+src_compile() {
+ asciidoc ${PN}.1.txt || die
+ mv ${PN}.1.html ${PN}.html || die
+ a2x -f manpage ${PN}.1.txt || die
+}
+
+src_install() {
+ doman ${PN}.1
+ dodoc ${PN}.html
+}