summaryrefslogtreecommitdiff
path: root/app-editors/bluefish/bluefish-2.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/bluefish/bluefish-2.2.12.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-2.2.12.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/app-editors/bluefish/bluefish-2.2.12.ebuild b/app-editors/bluefish/bluefish-2.2.12.ebuild
index 2580098daeac..5e75105359f7 100644
--- a/app-editors/bluefish/bluefish-2.2.12.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
MY_P=${P/_/-}
inherit autotools python-single-r1 xdg
@@ -18,8 +18,7 @@ SLOT="0"
IUSE="gucharmap nls python spell"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="
- sys-libs/zlib
+RDEPEND="sys-libs/zlib
x11-libs/gtk+:3
gucharmap? ( gnome-extra/gucharmap:2.90 )
python? ( ${PYTHON_DEPS} )
@@ -30,8 +29,8 @@ BDEPEND=">=dev-libs/glib-2.24:2
dev-libs/libxml2:2
virtual/pkgconfig
nls? (
- sys-devel/gettext
dev-util/intltool
+ sys-devel/gettext
)"
S="${WORKDIR}/${MY_P}"
@@ -39,21 +38,22 @@ S="${WORKDIR}/${MY_P}"
# there actually is just some broken manpage checkup -> not bother
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
-PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
-
-# eautoreconf seems to no longer kill translation files.
src_prepare() {
default
+
+ # eautoreconf seems to no longer kill translation files.
eautoreconf
sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
}
src_configure() {
- econf \
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--disable-update-databases \
--disable-xml-catalog-update \
--with-freedesktop_org-appdata="${EPREFIX}"/usr/share/metainfo \
@@ -66,27 +66,30 @@ src_configure() {
src_install() {
default
+
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
xdg_pkg_postinst
+
einfo "Adding XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
--add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
--add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
--add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
- /etc/xml/catalog \
+ "${EROOT}"/etc/xml/catalog \
|| ewarn "Failed to add XML catalog entries."
}
pkg_postrm() {
xdg_pkg_postrm
+
einfo "Removing XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
--del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
--del 'http://bluefish.openoffice.nl/DTD' \
- /etc/xml/catalog \
+ "${EROOT}"/etc/xml/catalog \
|| ewarn "Failed to remove XML catalog entries."
}