summaryrefslogtreecommitdiff
path: root/app-editors/bluefish/bluefish-2.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/bluefish/bluefish-2.2.6.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-2.2.6.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-editors/bluefish/bluefish-2.2.6.ebuild b/app-editors/bluefish/bluefish-2.2.6.ebuild
index 2c420dafef14..2e47961b2f0c 100644
--- a/app-editors/bluefish/bluefish-2.2.6.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.6.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime python-single-r1
+inherit gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}
dev-util/intltool
)"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
# there actually is just some broken manpage checkup -> not bother
RESTRICT="test"
@@ -60,12 +60,17 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -77,8 +82,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \