summaryrefslogtreecommitdiff
path: root/app-editors/diakonos/diakonos-0.9.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/diakonos/diakonos-0.9.4.ebuild')
-rw-r--r--app-editors/diakonos/diakonos-0.9.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/diakonos/diakonos-0.9.4.ebuild b/app-editors/diakonos/diakonos-0.9.4.ebuild
new file mode 100644
index 000000000000..f4bc35185127
--- /dev/null
+++ b/app-editors/diakonos/diakonos-0.9.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+inherit ruby-ng
+
+DESCRIPTION="A Linux editor for the masses"
+HOMEPAGE="http://diakonos.pist0s.ca"
+SRC_URI="http://diakonos.pist0s.ca/archives/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/curses"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/bacon )"
+
+each_ruby_install() {
+ ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${P} || die "install failed"
+}
+
+all_ruby_install() {
+ if use doc; then
+ rake docs || die
+ dodoc -r doc/*
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib spec/*.rb spec/*/*.rb || die
+}