summaryrefslogtreecommitdiff
path: root/app-editors/fe/fe-2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/fe/fe-2.0.ebuild')
-rw-r--r--app-editors/fe/fe-2.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
index ca6658d94079..207e9ec3f773 100644
--- a/app-editors/fe/fe-2.0.ebuild
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,10 @@ RDEPEND="sys-libs/ncurses:0=
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8-makefile.patch
+ "${FILESDIR}"/${P}-ar.patch
+)
src_configure() {
econf \
@@ -27,6 +30,10 @@ src_configure() {
LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
emake \
prefix="${D}"/usr \