summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-1.7.3.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.7.3.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild b/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild
deleted file mode 100644
index 6988d84d5c15..000000000000
--- a/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils xdg-utils
-
-DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
-HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
-SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND="
- app-text/hunspell
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwebkit:5
- dev-qt/qtwidgets:5
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- dev-qt/qtconcurrent:5
-"
-
-DOCS=( CREDITS.md README.md )
-
-src_prepare() {
- default
-
- sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
-}
-
-src_configure() {
- eqmake5 \
- CONFIG+=$(usex debug debug release) \
- PREFIX="${EPREFIX}"/usr
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
- einstalldocs
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}