summaryrefslogtreecommitdiff
path: root/app-editors/gvim/gvim-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index a68b9011e15f..2fe57d502981 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Please bump with app-editors/vim-core and app-editors/gvim
VIM_VERSION="8.2"
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby26 ruby27"
inherit vim-doc flag-o-matic xdg-utils bash-completion-r1 prefix lua-single python-single-r1 ruby-single
@@ -106,6 +106,8 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]]; then
+ rm "${WORKDIR}"/patches/006-vim-8.0.0617-crosscompile.patch || di
+
# Gentoo patches to fix runtime issues, cross-compile errors, etc
eapply "${WORKDIR}"/patches/
fi
@@ -319,7 +321,7 @@ src_test() {
# Call eselect vi update with --if-unset
# to respect user's choice (bug 187449)
eselect_vi_update() {
- einfo "Calling eselect vi update..."
+ ebegin "Calling eselect vi update"
eselect vi update --if-unset
eend $?
}