summaryrefslogtreecommitdiff
path: root/app-editors/hexedit/hexedit-1.2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexedit/hexedit-1.2.13.ebuild')
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
index 299f969f1681..d0b42fcc75f5 100644
--- a/app-editors/hexedit/hexedit-1.2.13.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://rigaux.org/hexedit.html"
@@ -10,15 +11,20 @@ SRC_URI="http://rigaux.org/${P}.src.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}"/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}