summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild b/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
index bcbba4882812..20c792e1d588 100644
--- a/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
+++ b/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
@@ -1,13 +1,15 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_COMMIT="6fa26b8dd2ac0931fe688370728c47086277d883"
+inherit toolchain-funcs
+MY_COMMIT="6fa26b8dd2ac0931fe688370728c47086277d883"
DESCRIPTION="Modal editor inspired by vim"
HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
SRC_URI="https://github.com/mawww/kakoune/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/kakoune-${MY_COMMIT}"
LICENSE="Unlicense"
SLOT="0"
@@ -17,25 +19,31 @@ DEPEND="sys-libs/ncurses:0=[unicode]"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2020.01.16-enable-ebuild-syntax-highlight.patch
+ "${FILESDIR}"/${PN}-2020.01.16-gcc-11.patch
+)
-S="${WORKDIR}/kakoune-${MY_COMMIT}"
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
-src_configure() { :; }
+src_configure() {
+ tc-export CXX
+}
src_compile() {
- cd src/ || die
- emake all
+ emake -C src all
}
src_test() {
- cd src/ || die
- emake test
+ emake -C src test
}
src_install() {
- emake PREFIX="${D}"/usr docdir="${D}/usr/share/doc/${PF}" install
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
- rm "${D}/usr/share/man/man1/kak.1.gz" || die
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
doman doc/kak.1
}