summaryrefslogtreecommitdiff
path: root/app-editors/nano/nano-6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nano/nano-6.3.ebuild')
-rw-r--r--app-editors/nano/nano-6.3.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-editors/nano/nano-6.3.ebuild b/app-editors/nano/nano-6.3.ebuild
index 9bd57c68b191..ff0fcf25cd44 100644
--- a/app-editors/nano/nano-6.3.ebuild
+++ b/app-editors/nano/nano-6.3.ebuild
@@ -91,3 +91,12 @@ src_install() {
use split-usr && dosym ../../bin/nano /usr/bin/nano
}
+
+pkg_postrm() {
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}