summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-9999-cmake_lua_version.patch')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
index 87a898032493..b14b3b992349 100644
--- a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
@@ -1,11 +1,11 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
@@ -464,7 +464,7 @@ endif()
+ # The unit test lib requires LuaJIT; it will be skipped if LuaJIT is missing.
option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
if(PREFER_LUA)
- find_package(Lua 5.1 EXACT REQUIRED)
+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
+ target_include_directories(main_lib SYSTEM BEFORE INTERFACE ${LUA_INCLUDE_DIR})
+ target_link_libraries(main_lib INTERFACE ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, fixtures for unittests is skipped.