summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-0.2.0.ebuild')
-rw-r--r--app-editors/neovim/neovim-0.2.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-editors/neovim/neovim-0.2.0.ebuild b/app-editors/neovim/neovim-0.2.0.ebuild
index dace3d4ec43a..374bd28354fd 100644
--- a/app-editors/neovim/neovim-0.2.0.ebuild
+++ b/app-editors/neovim/neovim-0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
@@ -32,12 +32,16 @@ CDEPEND=">=dev-libs/libuv-1.2.0
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
- jemalloc? ( dev-libs/jemalloc )
-"
-DEPEND="${CDEPEND}
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
virtual/libiconv
virtual/libintl"
-RDEPEND="${CDEPEND}
+
+RDEPEND="
+ ${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"