summaryrefslogtreecommitdiff
path: root/app-editors/retext/retext-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index aa9aaadfcf57..38c1165fb129 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -47,13 +47,6 @@ pkg_setup() {
export PATH="$(qt5_get_bindir):${PATH}"
}
-python_install() {
- distutils-r1_python_install
-
- newicon data/retext-kde5.png retext.png
- make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
-}
-
src_test() {
virtx distutils-r1_src_test
}
@@ -62,6 +55,16 @@ python_test() {
virtx eunittest
}
+src_install() {
+ distutils-r1_src_install
+
+ newicon data/retext-kde5.png retext.png
+
+ # Fixme: The application actually provides a desktop file which theoretically
+ # could be used, so far though I could not make it install properly.
+ make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
+}
+
pkg_postinst() {
xdg_pkg_postinst