summaryrefslogtreecommitdiff
path: root/app-editors/shed/shed-1.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/shed/shed-1.15.ebuild')
-rw-r--r--app-editors/shed/shed-1.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/shed/shed-1.15.ebuild b/app-editors/shed/shed-1.15.ebuild
new file mode 100644
index 000000000000..79499011aa1c
--- /dev/null
+++ b/app-editors/shed/shed-1.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Simple Hex EDitor"
+HOMEPAGE="http://shed.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-cflags.patch \
+ "${FILESDIR}"/${P}-interix.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}