summaryrefslogtreecommitdiff
path: root/app-editors/vis/vis-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vis/vis-0.3.ebuild')
-rw-r--r--app-editors/vis/vis-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/vis/vis-0.3.ebuild b/app-editors/vis/vis-0.3.ebuild
new file mode 100644
index 000000000000..e6ef1b663060
--- /dev/null
+++ b/app-editors/vis/vis-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
+HOMEPAGE="https://github.com/martanne/vis"
+SRC_URI="https://github.com/martanne/vis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ncurses selinux tre"
+
+#Note: vis is reported to also work with NetBSD curses
+#TODO: >=dev-lang/lua-5.2 (needed for syntax highlighting and settings)
+DEPEND=" dev-libs/libtermkey
+ ncurses? ( sys-libs/ncurses:0= )
+ tre? ( dev-libs/tre:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ncurses curses) \
+ $(use_enable selinux) \
+ $(use_enable tre)
+}
+
+update_symlinks() {
+ einfo "Calling eselect vi update --if-unset…"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ update_symlinks
+}
+
+pkg_postinst() {
+ update_symlinks
+}