summaryrefslogtreecommitdiff
path: root/app-emacs/a/a-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/a/a-1.0.0.ebuild')
-rw-r--r--app-emacs/a/a-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/a/a-1.0.0.ebuild b/app-emacs/a/a-1.0.0.ebuild
new file mode 100644
index 000000000000..a6fe49e7363f
--- /dev/null
+++ b/app-emacs/a/a-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Associative data structure functions for Emacs Lisp"
+HOMEPAGE="https://github.com/plexus/a.el/"
+SRC_URI="https://github.com/plexus/a.el/archive/v${PV}.tar.gz
+ -> a.el-${PV}.tar.gz"
+S="${WORKDIR}"/a.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}