summaryrefslogtreecommitdiff
path: root/app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild')
-rw-r--r--app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild b/app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild
new file mode 100644
index 000000000000..bf652da1d2f0
--- /dev/null
+++ b/app-emacs/basic-toolkit/basic-toolkit-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Basic edit toolkit"
+HOMEPAGE="https://www.emacswiki.org/emacs/basic-toolkit.el"
+# taken from https://www.emacswiki.org/emacs/download/basic-toolkit.el
+SRC_URI="https://github.com/gavv/distfiles/raw/master/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/windows app-emacs/cycle-buffer"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}