summaryrefslogtreecommitdiff
path: root/app-emacs/compat
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest2
-rw-r--r--app-emacs/compat/compat-30.0.1.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 73d9e9aff927..afdcb828e350 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,3 +1,5 @@
DIST compat-30.0.0.0.tar.gz 140329 BLAKE2B 7de4dffc518e521d0c15d3deb0f544972eb6660e19e3028f956b39b9ce355901f3d39339d9f2060a3b7754d67ec9ce92a720cc83afc468f3a2cedc189d8eb922 SHA512 04e2c26f6c1fbb78fc0f2de70913694b3f37614a6992b2a36cec5288c2083481701bdfb7d7e981582c8b22cf61b71e5a3e6011f86c1602331a26ad61c1fe2f66
+DIST compat-30.0.1.0.tar.gz 142477 BLAKE2B dc0f912f8c019846a6dde9c3013527589cb7b8f21cbc3478c16f0dd0edfca15a71f67df91b417ff26a401954b047bc7f6a7fc8efd6d874e3e96e17cf3acd16dd SHA512 cbab795c8ef890307eb6e161d900948a84948ea4b2462056a39ca21e8a4d0aebc985f7ff536658156e9d6e760e33b2b234bc2460f64193b9d07b733a267c1dfe
EBUILD compat-30.0.0.0.ebuild 1113 BLAKE2B 45e9257dc901aa54c64d0980d5f770c765ab7879f143ea2425b1ae31554e4b24a18722ed0353e41f3e93d39c84e1427f94f8d5cb7546dbe95ff45f7294d06220 SHA512 4ba0df372d3464b20d86d732acc30710dc9eb68110fdb9885a98a7d431d3af846087a8e12ed25b78d164d260126bd86749aba020e58d612cc0bc0ed1aae03e6f
+EBUILD compat-30.0.1.0.ebuild 1117 BLAKE2B ba1e4a97514f042981d9807f41d8b1f8bd6711a5683cd034f76c7f1002547093bc7513640cd06bed6bf0431f2b7bc161366f6dde9d4fb1b61ea4d6d19fabc448 SHA512 19cde0352962224fee026244aea48d26ea36c11466bc0edf962ead5f3cfe40e7b91f0a620e0fb812363889be0fd5ce8d58b9b90dd2d71229bfe8507938a33f0e
MISC metadata.xml 510 BLAKE2B 6d189301e592c47ca50f1e1a54b4b8ec6fe8f8883761137562eb1c0c2e898bf9d09c520d4ac4d2edcc851e29ad6896950d412aefb80320913405ee3b0c2b6b9d SHA512 85329976678ef5733a30ffa89fb41a4b8ccbeb8b977b9525c0dbd1b099c5afe12fa40b3c71b403893efdb7a31790ae9a46d01224f949f85ceecc94dcb5ef4fbb
diff --git a/app-emacs/compat/compat-30.0.1.0.ebuild b/app-emacs/compat/compat-30.0.1.0.ebuild
new file mode 100644
index 000000000000..0de9f6e50e90
--- /dev/null
+++ b/app-emacs/compat/compat-30.0.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ sys-apps/texinfo
+"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile "${PN}.info"
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}