summaryrefslogtreecommitdiff
path: root/app-emacs/eglot
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest2
-rw-r--r--app-emacs/eglot/eglot-1.17.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
index 111be65049fb..0cf936b5cadf 100644
--- a/app-emacs/eglot/Manifest
+++ b/app-emacs/eglot/Manifest
@@ -1,5 +1,7 @@
AUX 50eglot-gentoo-r1.el 83 BLAKE2B e148c24e445edbef0e208640a15221dfe01e311048174ca7679155b23799889e5ef6ed9d1c728c66b8a38a9734fde6a8c12afc68fb30b764030d1dcdcc3aa61d SHA512 e25a3dcc42e7e2892ddc52f881d88d75b82cb600a50b2f54f3fa669b2a55d3d214ec4a895d06efd015aadaeb4d642b46489a64833d086bd31635ace2853d23f4
AUX 50eglot-gentoo.el 82 BLAKE2B d5c0e215ceef684ac390a835633aca107f4ea95a83544779724c4fcf9a73963ba87d956aece3406d82bb02f82a5f9b909632d52e3b8fe361d26921f88d0f4e67 SHA512 9039a33b75c7101b04e367432f217700354fd2293914a295adfe3abd4ae1b8626205155fe8c0d809acf5d02b56af3feca22e837e926cba96d872fea4b3354a5d
DIST eglot-1.15.tar.gz 305200 BLAKE2B e9bb3f10dc9aac803f9b1184f489d76bd217b279d398c67a403c887298ec3e73e30a359a7e31af9c298b8778a2cdf916e9f40495ab3d01216a12fb38aed4d83b SHA512 871d56404c08baa490488d6027645f7ba0252faee7d006ade4e29890abb2e70a3f1715114c852721db7991bdece29266d920bbef6da0eb2ea2f37b842f411ac2
+DIST eglot-1.17.tar.xz 73488 BLAKE2B 291b9a79691839d7415ed7fb2af4317decb0e9d451a52fea688a56c590750142777a8cee3adc8dab3e227188a2c3c605089ea87adae107286cdc857a52372900 SHA512 3aa6b77431b8d313e16ac2b56615b759479125faf194c12f5d624733183220b1791b40596c29d9395182edf3380b4f5b217d6feaeaf334f8a633a295a3418f65
EBUILD eglot-1.15-r1.ebuild 883 BLAKE2B dbaf43a98bad694a5f27ec7f468be40f3c0a2a679fc3378a2712b39df2e56dbf1b13652221e9f48c5b7f769433181be7d8309ae2d453e86d623a609a16bde251 SHA512 05bbc88a38bd4d0d1a476b2e883023c9831c8cfb08311a39ac96d988a3c9621d8b98f23f3cda71dc77e6ff7990594fb6938d734159e5ac3668f24dee0d98a79f
+EBUILD eglot-1.17.ebuild 741 BLAKE2B b8a147cf638f3da5da73b8d7de6c81a19f2e673d8f7b078a865e8c1aa327715fe98c1f0a9423e3bb909070a0e03961d96bc11206754b6125ef88fda2d5e6d180 SHA512 b96ee5c40699857cc362d4ce55af52c558daae292b02d1989da1af85289397da0a9ebd6e520d63a2daebf59d6a425cf6ab60812baf5d4ac17df61da3d160fda9
MISC metadata.xml 701 BLAKE2B 436bc9f2720fad7cc3a7bcf9597a820317617ad7522e72c05417d6b9e1cb9c37d171ce5e24741b5730ab6708a0bcafacc8f41df3d4108926868887dc6ee25df3 SHA512 457dec4f625c37429917085c187e7c21ad1155217f79980033a7c0ecf62da941d340433ccbcbd5ae36a028aed7ab0cd1204e74985e36844e31829dab288c4fa8
diff --git a/app-emacs/eglot/eglot-1.17.ebuild b/app-emacs/eglot/eglot-1.17.ebuild
new file mode 100644
index 000000000000..92fa73df9dad
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="26.3"
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client for GNU Emacs"
+HOMEPAGE="https://github.com/joaotavora/eglot/
+ https://elpa.gnu.org/packages/eglot.html"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joaotavora/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/external-completion
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+ELISP_REMOVE="${PN}-pkg.el"
+
+DOCS=( EGLOT-NEWS )
+SITEFILE="50${PN}-gentoo-r1.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}