summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-daemon')
-rw-r--r--app-emacs/emacs-daemon/Manifest2
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.24.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
index e0330005ad17..5d942849114d 100644
--- a/app-emacs/emacs-daemon/Manifest
+++ b/app-emacs/emacs-daemon/Manifest
@@ -1,5 +1,7 @@
DIST emacs-daemon-0.22.tar.xz 5276 BLAKE2B a866b14951df94e1d382253dcb7045beb800c9dd754f7eed40eadecde43fd583bb2bc20ad9ccc9f87174b06aadbb26f7875deaf36d9bb5325f98ffa58fded8c7 SHA512 f013cd00d3a24ca348bf718dd20dec7bea89107c0a27c921d6b58595b611991830604fc658d57681708218fbee1dae6dd0b277a2a9da67639e3553e0fd133094
DIST emacs-daemon-0.23.tar.xz 4876 BLAKE2B 95fd9fc2b038dd60d4fc889674f4f1c3e5c0f8894a0161a0ea626835e91d500766e7fb50f8efafd70b0a45129626968147009c218b55ca0df6c6da50b8cb99dc SHA512 90f4b5b22df17106173de6116f45d902613b60b4b837293ea5f7843ad4967f68f9920cb301ef1edc50c6c831941be487b456ac8c1bc41ae41a55c6e1ea135343
+DIST emacs-daemon-0.24.tar.xz 4556 BLAKE2B a4b6809771c6f6c9d7b4b45ea9fe95f2274ecf9006aecb473636258d9681ebf80099be3a7fe5119d6bfc31e89846fc9b5b04954b3614be2382e1ee8078c44919 SHA512 d5a08e997a20907b6251bcfb0f8af022648adb8311af7fcb94aad73c1b579eb16dd2ea17325d86f293940dd56eb2de47df29c2b98b4ca591ceac0d97120dcf23
EBUILD emacs-daemon-0.22-r1.ebuild 1606 BLAKE2B 1d521e7d5177e864bcc365e7fe978ea4380b68380d69e542c7b1801723657dee2780b2e2441d6b5831712b550e0763f36878b913cc0acb3e42a5d1f5d9df994c SHA512 e3f1fac107add3017b522e446f22c81910cb67e05bb4008d061d371a7e7336942fef33fbd426e13ac0dda94701f1cb4fb16cf860d57c36121948dd3414c62ef0
EBUILD emacs-daemon-0.23.ebuild 1655 BLAKE2B 0f04993f482708927f2e06779a588af9ff97935d2de7a1c04f8493d9c072cdbd8672f06fa864ba44b0d7ccd4c4f9366ff666b7478259d03d8ff7bd42343badf4 SHA512 3be88552eea164aa17a0dee904c10d8d26ea9faae31692b8dfb9efeabccd74aedeae3fd075e03596d5d26be9eb46fbc3845878f828310b709cb67e71f3a3175c
+EBUILD emacs-daemon-0.24.ebuild 1788 BLAKE2B 598229a553654d2716aa8f0ec7474fade7f4262883015fde132cf7aad4278fec73fd6872f9ef020bb56f79855f6e84b6b60a17c368c1f09471c9caec2b6c53dd SHA512 4de08a0ec193611b5d64af7ed4fbb2adf2da6c1eb3d1f3fa24e46fb0faad5e54cb1913746c528f22fcc92d88f3c26018aaae46ff35bd561ca636a4819de10132
MISC metadata.xml 362 BLAKE2B 59c9e3025bdd347e4812d6485bda2b731a1b0adf2eec16aefdd6b0d3379a949cd99c637febfcab0c6314c457eafe0727a986196e4499aa29dbd297a6a0458d66 SHA512 5882c9372b62c44189426a1ea3ac975e29b70fc5b5d30a3f024edced82d9406e118e9acee91b1353c76eb65f19008e4bb1475f859509c933be48c03aa701394b
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.24.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.24.ebuild
new file mode 100644
index 000000000000..fdda794a5706
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.24.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+if [[ ${PV##*.} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/emacs-tools.git"
+ EGIT_BRANCH="${PN}"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
+ S="${EGIT_CHECKOUT_DIR}"
+else
+ SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/emacs-common-1.11"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://gitlab.gnome.org/GNOME/gtk/-/issues/221> and
+ <https://gitlab.gnome.org/GNOME/gtk/-/issues/2315>.
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ dodoc README ChangeLog
+}