summaryrefslogtreecommitdiff
path: root/app-emacs/highline/highline-7.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/highline/highline-7.2.2.ebuild')
-rw-r--r--app-emacs/highline/highline-7.2.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/highline/highline-7.2.2.ebuild b/app-emacs/highline/highline-7.2.2.ebuild
new file mode 100644
index 000000000000..88910bb89a8b
--- /dev/null
+++ b/app-emacs/highline/highline-7.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Minor mode to highlight current line in buffer"
+HOMEPAGE="http://www.emacswiki.org/emacs/HighlineMode"
+# taken from: http://www.emacswiki.org/emacs/download/${PN}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ppc ~s390 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}