summaryrefslogtreecommitdiff
path: root/app-emacs/jinx
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/jinx')
-rw-r--r--app-emacs/jinx/Manifest2
-rw-r--r--app-emacs/jinx/jinx-1.11.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index 461b77933d33..872e5bffd397 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,4 +1,6 @@
AUX 50jinx-gentoo.el 191 BLAKE2B a183a9485eea61590192547a8c99e8c974b1974851073a49a33304ec0d9d43158279669aa8dc2ca26d9521c61b229c9fd490dec81643126f678585974dea7483 SHA512 dc0378743253f61f1c94d7fbcf8e3fff767296eecb26e856bbb5f24409b879e3d1a4f52efe87ea0ce106281b216396e94a72a7842b0fe4a48a80b4c41cb05921
DIST jinx-1.10.tar.gz 35304 BLAKE2B d112de93fab933782110f8587cc5c55e63429153ce205ae44ae53b86be669064961cebf688a8159cd09c53538ebd488d687939c01d21be318ef4cd2bfc930f85 SHA512 66f99dd5e2028770bed99a77c1364456309843f6efb4726b2cff093a0f721a54f58b72be324718c4ab55e7d54f2bf48bd4480cef4cd25c54b6ffc9f08de16ba6
+DIST jinx-1.11.tar.gz 35970 BLAKE2B b8d9299faf5df8d4eef74e8f3a4df7a83fe1dfb4e7a904491f14f2f0c03d0b0582f3b3b1ebebcbe6076ab7621b855e85d5d6ea0c38a8e77e8cae1d594efa850b SHA512 1a1f6603933fc4922b1398bb7d0460854782b2e53dc4364f8d0c27b98534d0aa32ee085a5f667df76e7f2ec5115c4afdc08d85134c75abb053bd0845b35b7f81
EBUILD jinx-1.10.ebuild 1049 BLAKE2B d8e1ccabbef2313d85511e858017cf134cd02bb0a64ebc409e166f563ea7f86898e8551752941e8d0afe04774cba5a92fe639a0ed4318499b982f207dcf2cd37 SHA512 3ab6a73217fbd85c1a4044a75a2abb044176dfb4df7be291b0cf1096752302a2186b953276b43e82e9dae93066b51f80ec85fa623588a2d2d262b68fbd34add5
+EBUILD jinx-1.11.ebuild 1050 BLAKE2B d85403d5126824ffa477dab2052dc761664daf072d4e96c201aaf696d34225d239c2a0530dfaee847591d47f17c7f069c797fce50f9545fe5b740948eede1756 SHA512 6eac90491ec2541023c171f4bea54a832a3593e91632d192086713351315cf743d95c28dda383e2875cc3d7de46b52da8d7314b30997ab5a27a6af9182a27f61
MISC metadata.xml 596 BLAKE2B 637e6f9f170f3ce64857712ff8156e123e42fa1e3495291ca05fc260f69ba267df6536c08b2a1ba042d8cc13f86f499d1e5f8dd223b89efd2c62ca38a9f37d2d SHA512 1fd1a6b8ba360f7aa2c03e8c318482b564afcf2392c20fe0c70d96b181df9323706c3b81bd3aa98916b65cff29aafcf9c9a486bfbbd55b775ff7adee85886950
diff --git a/app-emacs/jinx/jinx-1.11.ebuild b/app-emacs/jinx/jinx-1.11.ebuild
new file mode 100644
index 000000000000..2c768143a124
--- /dev/null
+++ b/app-emacs/jinx/jinx-1.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=28.1
+
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}