summaryrefslogtreecommitdiff
path: root/app-emacs/llama
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/llama')
-rw-r--r--app-emacs/llama/Manifest3
-rw-r--r--app-emacs/llama/llama-0.6.0.ebuild40
-rw-r--r--app-emacs/llama/metadata.xml18
3 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/llama/Manifest b/app-emacs/llama/Manifest
new file mode 100644
index 000000000000..2937efb82702
--- /dev/null
+++ b/app-emacs/llama/Manifest
@@ -0,0 +1,3 @@
+DIST llama-0.6.0.gh.tar.gz 22503 BLAKE2B 681f0596430b6396ceb1fc53af98f6baaad8588e2794aa8bc050ade0f6fa04d0e683145c5fee49ae2c63e10819b90931d484989bf78a152f6162c03d798bc865 SHA512 36f4c4a90ec65562470cef08751dd68bd8dcee9556e6d30a219e0491819ec137afd1fe5a2ae2465e8eb48cd54ee4b7ee251cd455786c8c9b9ba44f388c79ce41
+EBUILD llama-0.6.0.ebuild 687 BLAKE2B df4e2bf2a0bdf582a3c4db4efcd5a9c0d2725b972fb13e43e7e1b2c30f14509a00be8f178766c13a519b711b9b5f18ead9221e2d94e9d199fb8ca0aa1baa0e88 SHA512 9bd666385ab1ccf5f929bbe64cc757bf0d0a80c6ab6557371c72f2bae997de57d354c68be6f6f3046504c501d32d356d97407d619a60e4b3e251b1e53d1e8982
+MISC metadata.xml 595 BLAKE2B 0d9521d8b089e757dfff8eaa20cdd7d742dc43e52f537f744995b377343d39a47dff1f49f9b64549a26f78762dbf4edec91dae8f27115bb9af6e80eac4dab0d5 SHA512 618a0daefefe838311d301c1ab71df38a806c6de36536975007056576a84cafcb061315699a3cd71ced4c9e014ea9cf29260b3ed7fd3eefe7e12a215ee300eca
diff --git a/app-emacs/llama/llama-0.6.0.ebuild b/app-emacs/llama/llama-0.6.0.ebuild
new file mode 100644
index 000000000000..cefa424406d9
--- /dev/null
+++ b/app-emacs/llama/llama-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compact syntax for short lambda"
+HOMEPAGE="https://github.com/tarsius/llama/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/tarsius/${PN}"
+else
+ SRC_URI="https://github.com/tarsius/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert .
+
+src_install() {
+ rm "./${PN}-test.el"* || die
+
+ elisp_src_install
+}
diff --git a/app-emacs/llama/metadata.xml b/app-emacs/llama/metadata.xml
new file mode 100644
index 000000000000..b635a332c22c
--- /dev/null
+++ b/app-emacs/llama/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package implements a macro named ##, which provides a compact way
+ to write short lambda expressions.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <bugs-to>https://github.com/tarsius/llama/issues/</bugs-to>
+ <remote-id type="github">tarsius/llama</remote-id>
+ </upstream>
+</pkgmetadata>