summaryrefslogtreecommitdiff
path: root/app-emacs/python-mode/python-mode-6.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/python-mode/python-mode-6.2.0.ebuild')
-rw-r--r--app-emacs/python-mode/python-mode-6.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-emacs/python-mode/python-mode-6.2.0.ebuild b/app-emacs/python-mode/python-mode-6.2.0.ebuild
new file mode 100644
index 000000000000..089fa115e867
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."