summaryrefslogtreecommitdiff
path: root/app-emacs/svg-lib/svg-lib-0.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/svg-lib/svg-lib-0.2.5.ebuild')
-rw-r--r--app-emacs/svg-lib/svg-lib-0.2.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/svg-lib/svg-lib-0.2.5.ebuild b/app-emacs/svg-lib/svg-lib-0.2.5.ebuild
new file mode 100644
index 000000000000..c392b21873b6
--- /dev/null
+++ b/app-emacs/svg-lib/svg-lib-0.2.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+inherit elisp unpacker
+
+DESCRIPTION="SVG tags, progress bars & icons"
+HOMEPAGE="https://github.com/rougier/svg-lib"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}